Tracking: CIP Parameter wird nicht ausgewertet


#1

Hallo Leute,

ich habe ein Problem beim Tracken von Zugriffen ins piwik. Die Client IP (CIP Parameter im Aufruf) wird nicht ausgewertet.

Die Zugriffe sehen immer in etwa so aus (Tracking PHP): https://myserver.com/piwik.php?idsite=1&cookie=fasle&rand=0.17469201779243182&cip=**IP**&ua=Mozilla%2F5.0%20(Macintosh%3B%20Intel%20Mac%20OS%20X%2010_10_5)%20AppleWebKit%2F601.3.9%20(KHTML%2C%20like%20Gecko)%20Version%2F9.0.2%20Safari%2F601.3.9&_cvar=[[“ “,” “],[“Cam”,””],[“Lang”,”de”],[“var1”,”value”],[“var2”,”value”],[“other”,””]]&cvar=[[“ “,” “],[“var3”,””],[“Lang”,”de”],[“var4”,”value”],[“var5”,”value”],[“other”,””]]&token_auth=TOKEN&url=&rec=1&action_name=index%20de%20app%20&_id=ff66dd33cc22aa55&apiv=1

(idsite, cip, custom variablen, token_auth wurde hier geändert)

Es wird immer nur die IP, City etc. von dem Server getrackt, von dem der Zugriff kommt, nicht die Client IP.

Mir ist bewusst, dass ein Token mit Admin Access für die Site verwendet werden muss. Das wird hier auch, die Rechte stimmen für das Token bzw. die Site.
Mit tracking_requests_require_authentication = 0 in der Config funktioniert das, City, Provider etc. werden korrekt bestimmt.

tracking_requests_require_authentication bewirkt ja nur, dass das Token im Tracking-Request nicht mehr beachtet wird.

Wo könnte das Problem liegen, dass die Infos anhand der CIP nicht korrekt bestimmt werden, obwohl das Token Admin-Rechte auf die angegebene Site hat ?

Vielen Dank im Voraus !
LG


#2

Niemand eine Idee ?

Für mich ist das sehr wichtig, habe aber leider keine Idee…


#3

Hallo zusammen,

sry, aber ich muss den Fred hier nochmal pushen, bin leider immer noch nicht schlauer mit dem Problem. :frowning:

Jemand eine Idee dazu ??