Track HTML-Newsletter


(heinetz) #1

Hi,

i set up a piwik-installation for my customers website few weeks ago.
it has been easy to install and after some configuration now it runs fine
for me.

i also send out multipart-newsletter for my customer and he asked me,
if it is also possible to track it. i never thougt about it but i could imagine
that i could do this also with piwik.

would that be possible ?

best,
heinetz


(rschilt) #2

heinetz,

If you are talking about a newsletter being emailed out after readers go through a subscription process - then it’s not possible with a standard Piwik install. Currently Piwik tracks data as visitors move through a site and/or click on links.

It might be possible to achieve this by executing a custom javascript as the newsletter is being emailed out.

Perhaps you might like to consider logging a ticket under “Feature Requests”.


(vipsoft) #3

Wait for the server-side tracking API (ticket 134).


(heinetz) #4

ok, thank you for that information!

best,
heinetz


(heinetz) #5

hi,

i decided to track only the clicked links in the newsletter to the tracked homepage
and found a way for me here. i use the campaign-feature. that works fine for me!

few questions anyway style_emoticons/<#EMO_DIR#>/wink.gif

i’me testing it on my development-system. the request:

/?piwik_campaign=my_campaign&piwik_kwd=clicked_this_link

… is displayed in the campaigns-tab as expected but when i tried to change the
campaign by changing the value of piwik_campain it seemed to to be tracked
anymore ;( i tried another browser and it worked.

the question is, how can i reinit it and am i able to delete tracked campaigns?

best,
heinetz


(heinetz) #6

hi,

i tried and tried to found out style_emoticons/<#EMO_DIR#>/wink.gif

to init the system for tracking a new campaign a have to remove my last visit
into piwik_log_visit then delete browser-cookie and than the new visit with
?piwik_campaign would be tracked as new entry into campaigns BUT if found
something else, what is a new problem for me:

i work with ‘setCustomUrl’ and when i define a custom url the campaign
wouldn’t be tracked anymore !

do i do something wrong or is that a bug ?

is there any solution ?

best,
heinetz