"Today" not real time! even with edited config :(


(eugen723674) #1

Hi Piwik Team!

I would like to have the actual date … “today” in real time if i choose it in my piwik.
So i read the FAQ and seen:

Are Piwik reports real time?

By default Piwik reports are real time when you select “today” in the calendar. Piwik will look at all your logs for today in the database and process the reports every time you request them.

Piwik will process your visitor logs and build the reports when you request them, assuming your config file has the default value to enable real time reporting: enable_browser_archiving_triggering = 1

By default, reports are kept for 10 seconds. You can change this value in config/global.ini.php:
time_before_today_archive_considered_outdated = 10

So i have added following lines to my config.ini.php:

[General]
default_day = today
default_period = day
visit_standard_length       = 3600
enable_browser_archiving_triggering = 1
time_before_today_archive_considered_outdated = 10

So if i log in to my piwik he will show me the todays data and not from yesterday (working fine) and should refresh all data if the today-page is not refreshed in the last 10 seconds (not working).

I am running piwik since 2 days. yesterday with 50 visits, which my piwik shows exactly. But for today he shows only 7 visitiors (till yet) - but in the databse are 65 entries on my piwik_log_visit !

65 - 50 (yesterday) - 7 (which piwik shows me for today till yet) = 8

So i am missing 8 visitors and piwik should show me 15 instead of 7 visitors vor today.

i waited several minutes, i refreshed the page, i switched to week, year and back to “today” but he still shows me 7 instead of 15 visitros for today.

why???

my entries on my config.ini.php (as shown above) should deliver my today-data in real time (with 10 seconds pausing). right?

Hoope you can tell me why its not working. style_emoticons/<#EMO_DIR#>/sad.gif style_emoticons/<#EMO_DIR#>/smile.gif

Greetings
Eugen


(vipsoft) #2

php’s date.timezone (default is eastern if not configured in php.ini) must match mysql server’s timezone.


(eugen723674) #3

Hi vipsoft!

OH OK … lol - now i know why it’s not working style_emoticons/<#EMO_DIR#>/wink.gif

I checked the php date.timezone with phpinfo. At the moment it is:
date/time support enabled
"Olson" Timezone Database Version 2009.9
Timezone Database internal
Default timezone America/New_York

I also checked the generel server time (whm/cpanel) which says:
Mon Oct 12 17:15:00 EDT 2009
./posix/EST5EDT

The mysql tells me:
system time zone EDT
time zone SYSTEM

So i am kinda noobish … but as i understand that the server time and the mydql time are both EDT and this should be ok. Only the php timezone is NewYork which is not EDT i think, right?

I tried to change the php timezone in my php configuration option on WHM but didnt find any possibilty to change the timezone style_emoticons/<#EMO_DIR#>/sad.gif

Can you help me and is what i said correct?

Greets
Eugen


(eugen723674) #4

Me again … i think it is working now!

As i checked … NewYork is also EDT timezone.
So all 3 timezones (server, php and mysql) are now the same and it should be fixed, right?