The plugin 'UserManager' is not activated -> when using API


(Kidder) #1

Hi Everyone,

I am new here - but what a great piece of software. We have been testing out the API and everything looks great - we are able to get all sorts of data out of the database. But we have hit a stumbling block and are looking for some help style_emoticons/<#EMO_DIR#>/smile.gif.

We have reviewed the documentation and the forums but can’t seen to find an answers – soo … hopefully forums can help.

We wrote a quick snipped of code to try and add a user to the database:
$request= new Piwik_API_Request(‘
method=UserManager.addUser
&userLogin=username
&password=userpassword
&email=user@domain.com
&alias=TheBooger
&token_auth= XXX
’);

But every time we try and run the code we get back:


Now we have been to the plugin admin page and it says it is activated. We have even checked in the database to make sure it is activated (and it is!). We have also tried deactivating and re-activating - but we keep getting back the same error message.

Does anyone have any ideas why this error would be thrown - when the plugin is obviously installed and activated?

Also, using version 0.5.5

Thanks in advance
Curt


(Kidder) #2

Fixed the “issue”. As it turns out the plugin is UsersManager.addUser and not UserManager.addUser. style_emoticons/<#EMO_DIR#>/smile.gif