Testing a previous Piwik version in a tagged branch


(Tassoman) #1

I’m trying to run tests on a previous Piwik configuration (v 2.9.1) but I can’t run integration tests because of the following error

php console tests:run Integration
Executing command: cd /var/www/piwik-dev/tests/PHPUnit && …/…/vendor/phpunit/phpunit/phpunit --group Integration
PHP Fatal error: Uncaught exception ‘Exception’ with message '
Piwik should be running at: http://unknown/piwik-dev/ but this URL returned an unexpected response: ‘ERROR fetching: curl_exec: Couldn’t resolve host ‘unknown’. Hostname requested was: unknown’

’ in /var/www/piwik-dev/core/SettingsPiwik.php:332

As you can see http://unknown host doesn’t exists, should be http://localhost or ip address.

the steps I’ve made were:

git clone GitHub - matomo-org/piwik: Liberating Web Analytics. Star us on Github? +1. Matomo is the leading open alternative to Google Analytics that gives you full control over your data. Matomo lets you easily collect data from websites, apps & the IoT and visualise this data and extract insights. Privacy is built-in. We love Pull Requests! piwik-dev
git checkout tags/2.9.1 -b 2.9.1
git submodule update --init
php composer.phar install

Environment should be ok but I still get the previous error when running integration tests.
php console tests:run works flawless until Unit Tests are finished.


(Tassoman) #2

Unluckly I’ve also tried adding [tests] variables inside config.ini.php

[tests] http_host = "myhostname" request_uri = "/piwik-dev/" remote_addr = "127.0.0.1"


(Matthieu Aubry) #3

Hi @tassoman
we don’t support running tests in older version, we only support current latest version of Piwik


(Tassoman) #4

Well, I see, can understand :blush:
So I suppose the only way to query local Piwik’s APIs and a remote Piwik from the console It’s providing a set of commands by a generate:command plugin proxying to APIs calls with right parameters.