System check complaining Archiving is not running, even though it is

I’ve got an issue with the archiving. I have it disabled in the browser and have an hourly cron job that runs it. I record the output to a logfile, and I can verify it’s running every hour.

The problem is that the Matomo system check sometimes starts complaining that it hasn’t been run in some number of days/weeks/months under “Last Successful Archiving Completion”, even though it’s running every hour.

Also, even though I have “automatic updates of GeoIP databases” set to update once every month, from the core:archive log, it actually gets run every hour instead. Maybe the problem is related, I don’t know.

Any ideas? At one point, I downloaded and installed a fresh copy of matomo on my server just in case something had gone off with an old update or something, but it made no difference.

I think I partially solved this by running the core:archive as the web server user instead of root. It still seemed to be archiving before as root, but for whatever reason it wasn’t recognizing it or recording it properly I guess.

The problem with the GeoIP database remains, though, as it still gets downloaded every time core:archive runs, but the actual geoip database doesn’t get uncompressed and updated.


Does your webserver have write permission to the misc/ directory?

Yes, the webserver has write permission to the misc/ directory.

I manually extracted the .mmdb geo database to the misc directory myself, and then it stopped downloading it every hour. Maybe something got out of sync when the core:archive was running as root, not sure. I’ll see if the problem reoccurs next month when it’s due to download again.

Thanks for your reply.

1 Like
  • We restored a backup of our production msyql database to a new aws/rds/mysql database, then stood up a new aws/ec2/linux instance and connected it to the aws/rds/mysql database.

  • We disabled the “archive reports when viewed from the browser”, implemented an hourly cronjob to do the archiving. Although the cronjob archive has ran many times in the past week, we still get the " Uh-oh! Matomo has detected some critical issues with your Matomo setup", and the only red x in the list is the “Last Successful Archiving Completion”, which says “Archiving last ran successfully on Thursday, January 2, 2020 13:03:58 which is 13 days 01:19:26 ago.”. Coincidentally, Thursday, Jan 2 is when we setup this new environment!?!?

  • We confirmed the conjob is running as apache.

  • Although this is a test environment that has a copy of our production data, we setup one test site to see if it was tracking properly, and it is…

  • Any other ideas as to why the archive process is not updating the last successful runtime?

System Summary

442 users

92 segments

49 goals

0 tracking failures

596 websites

47 activated plugins

Matomo version: 3.13.0

MySQL version: 5.7.22-log

PHP version: 7.3.13