Stuck upgrading to 1.8.4

this is the third time I’ve been through the “Database Upgrade Required” screen. The last time was successful with a “continue” link -but then the upgrade screen appeared again? I also tried running the SQL scripts manually since it failed first time. Have I created some kind of evil install loop?

I’ve not read about many problems with this update…so not sure what I’ve managed to do! Currently I can see executing: “copying into tmp table INSERT INTO ‘piwik_log_Action_duplicates’(…”

any ideas on this? I’d prefer not to roll back to the previous backup, but we’re approaching a day’s loss of data anyway


does the mysql query above never finish running? how big is your DB? it took 10min to run on our 15G DB.

in the end I ran through all the queries manually and it worked -but odd that the page indicated it was finished (not timed out etc.) but then continued back on to the upgrade screen? Anyway, it’s up now, but I’m not seeing any improvement in the archive times -running it yesterday took 68 minutes which I think it was doing before, and why I changed it to run daily -has something messed up with the install possibly?