stream_set_timeout()


#1

I’have this error just installed piwik, Warning: stream_set_timeout() has been disabled for security reasons in piwik/libs/Zend/Http/Client/Adapter/Socket.php on line 240
how to solve this?


(Matthieu Aubry) #2

please ask your webhost to remove this function from disabled list since this is not related to security and shouldn’t be disabled (it is required by Zend one library used by piwik)


#3

oke thnx…


(vipsoft) #4

Out of curiousity, can you post the output of:


<?= ini_get('disable_functions') ?>

Thanks.


#5

[quote=Anthon]
Out of curiousity, can you post the output of:


<?= ini_get('disable_functions') ?>

Thanks.[/quote]
Where leave I this code?


(vipsoft) #6

Just put it into a new .php file anywhere in your webroot, navigate to it in your browser, cut&paste the output, and delete the file afterwards.


#7

This is the outputted code…


dl,show_source,chown,shell_exec,exec,virtual,passthru,proc_terminate,system,pfsockopen,leak,apache_child_terminate,posix_kill,posix_mkfifo,posix_setpgid,posix_setsid,posix_setuid,escapeshellcmd,escapeshellarg,proc_close,proc_open,ini_alter,popen,pcntl_exec,socket_accept,socket_bind,socket_listen,stream_set_timeout,getrusage,get_current_user,set_time_limit,getmyuid,listen,chgrp,link,symlink,dlopen,proc_nice,proc_get_stats,proc_terminate,shell_exec,sh2_exec,posix_getpwuid,ini_restore,mkfifo,posix_mkfifo


(vipsoft) #8

Ok, if your admins won’t enable it, there’s a workaround in trunk.

http://dev.piwik.org/trac/changeset/5166


(Matthieu Aubry) #9

Anthon error happens in Zend: piwik/libs/Zend/Http/Client/Adapter/Socket.php
so it will not fix it i think


(vipsoft) #10

Right. Won’t help for RSS feeds, but should help with update check and SEO plugin.