Strange output after update to 1.1.1 (solved)


#1

After upgrading to 1.1.1 I get a strange output when I change the date range (see below and image attached). Clicking on “Overview” gets me back to normal.

So far this has only happened in Firefox (3.6). I logged out, cleared caches and deleted cookies, but the problem stays the same.

This is the output:

���������������������HTTP/1.1 200 OK Date: Tue, 11 Jan 2011 00:35:05 GMT Server: Apache Pragma: Expires: Cache-Control: no-store, must-revalidate Content-Encoding: gzip Vary: Accept-Encoding Keep-Alive: timeout=5, max=196 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html; charset=utf-8 b7e ��������Z�r�8}���͔���dn�q�-Ǘ�3���Lj&q� �%bDZ����-�2߰O��� EJ�6S��rD�e��qi�|�\�ƚ�1�9�u�7:�I��?��hI� �f�+�Gf�e� ipw&�����7�$��N�����1�S~��{b�"M)a�P�aJ�q�%ԣ8 �.�/"��"Gd�.$U�5:qQ�+� �ѱߏ��af��<RuW2��Q�PH��A��A\�q��7}��Ȫ� �x>1�wl-��31��"18%-h�r���V�\wRɯ�?Ud��_�� ��s�֜Wkn2�#V�y�y�Zs�g2Um’YO8�Un4�F횞������������ok�ȫ���$���֜��Z���k ;|X��sM�u�¶&DapՀ)l�z*\�S�qp4i���)l�Zb�S���7 2�O�߀�L?����Hf�� ��}N;@��l~e5Q�1G ��d<�&��5se��\�,��G� ���BL� �_�� �k1�El�m��}]��S��V�[à��jt<ԇ’aeq(bSW<�Y���BRD_0 a?_���䥫E���:�V��.��q�wD��Tzwa�w%a� �{� !��g!q�cCP$)��5$� �� >�{/m����Lu%eF��Ѩ�?��"����޳�娟A��!L�q7La��uʋb����s|P��㛙� a�e�Mq#�U�����b��Gj�R�4a�ؤM�wwH��fJ%�’I&Uu��’3��E �d�)�59�Q<�e����Ġ5fS6����6��#�F: ��6�� ."149�e�7p�.��l$3�]Y�F��E ���9A;�8c�eв�=m��S��ESH�-j�n�䫒��=#��3�5U����s�Qq9q���~�H�B��� �qN�ew0��H��)|�=�L�cG(�ڧ�<���4��̌����e;.� 2��?>�������ٻ7�wa���s3��e�"B\�A�ٝ��&�[��o�����xY/=��ScL?|�98��#�S�y�L�~�3S8�zQⴏ��D��eIǾ�/!WaR�a��c*i�mcϝ9���PSIa�h�Q�bAV�*��޿�Ģ��c�#�� ��J��K;��N{!O���ef0Ff.�$��@�G����†BSŊZ�ɽS�;%ܝĎM��X�J�Yi}3��K����Q�n�Tt����v��S\��� >�S!=լ;W��Y[M��>:߄%X�{pE�G�kLa�L��~N��8��w�(%��P.��� ����l���e�%�ↅ�=�r�]¸�b�큜�4�+D ��_��|���$��pZb��H�&&G��4a�k&��Ñ������ׁ0��a��R��T*j��*a��K�^�I�C��N}}6~3&��� ���% $�g�p�=Z-�T�a��JJ'64�d)�e�fF4Q���;H^r��3Idley���#$��u���H���E��M�j��ȕ/�X�D�8�i 44�e��jX�Gb�M�e���&SV�W�5�Ȝ��c:+>FϞ�wܜ��C�G&�n���� �nư⊿�D������L����ux|�,“�]$k�0p1�1ۯ�1O�)�5LzH,_��B�u�PS����Lx��F�K0[(�:��Eo�<���Z��]���-�s�k��zX�����ٔw������7�mβ��XYi�b��OVg=6�6��8��F���5�c�q�V*�W��X�����(46����� T{aI�v�A_�e�.�{�7��.v�� o��5��n5>2ڨ�T�����fZ"�ɘS�#�pi��F�n?��[_��m����7ZY�s������{8+�a(�P�/��\���(t�������!<�Br�ܣ����h�����҂$LB�\��v��~�L���-M”,����x���@�-��8:#p,�����8a�� ^�a?�Րr�@c�6L���jiڕ�,�U�C�J�G^K1U͹�E�@>�E&[?���v>�p�7�����.�)B@>v�8t��58�^z�،�%^ H�!©���5n���#�Lڙ���%��0H�:L.{e@�R��>��K�a�r�bqX�?�PYC<�e�֟����q�(��rҜ6�a�=d�tL��Z��/M��˓�|��wk}s�es(6O�O��45������Iq��E~��hن�h��ş+e�,�dn3�7�����$��1��)ɯ8��G���#�3������g��o��=���eq_٣ݟsGx �^�zxe��X����,N/������|O[�p��?��=��e�V�̶H��%=M�gn��+�’Oؠ��1H&��Vt�� ���&��AP/���]�Z�����g�1�x}��7/���wssԆT�q+_��������w��߽���\y&w��Ex^�j�� s���xTBŭZ��ݦ�:�3]J.^c�j� >�YK: �i-�1�L�<�О-��b8��v��n���PD �K��=3X�gu9�M���’-t��3j�’b�ki��b���c|���@��L��!�W�ݹ&S��LS��o���b���H��pN{~��Lh��[�n �E�w ��6�¾�5�J�w�S�/j:�y��!� }��<��1�F��c��J�%]�>�n���F��2�1��!5΀nġ�~B�D�u��9�t�a���’%����9_��*��^����a�;@g�d��ϓ��� �R�Jo�p��D3��I�Iyu�-yu�Z���������:�{-�� 0


(vipsoft) #2

Piwik goesn’t compress html output, so the broken compression is probably a conflict between Apache and your php.ini settings.


#3

Thanks vipsoft. Can you also tell me how that conflict could be solved?


(vipsoft) #4

There are a number of different settings that could be causing it. You’ll have to check your Apache config and php.ini.

Examples:

  • Apache: mod_deflate
  • PHP: output_handler, zlib.output_handler, or zlib.output_compression=On

(Wrappers using auto_prepend_file/auto_append_file may also have an effect.)


#5

But why would those settings cause trouble if they didn’t before the upgrade? Has something changed regarding those settings in 1.1.1?


(vipsoft) #6

See if this patch helps: http://dev.piwik.org/trac/changeset/3630/trunk/core/Piwik.php


#7

No, that patch doesn’t change anything.


(vipsoft) #8

Piwik can’t detect Apache’s mod_deflate, so try disabling that, and restarting the web server process.


#9

Hm, I can’t do that myself, I’ll have to ask the provider. But was this any different before 1.1.1?


#10

Has been solved by disabling the following in php.ini:

;zlib.output_compression = 1
;output_buffering = Off
;output_handler =

Thanks for the hints.