Stop emails from cron archive job


#1

Hi all,
I’d like to stop emails being sent to me every hour from Piwik. How do I do that?
Here is the Subject for the email being sent to me:
Cron xxxx@c2s1-1e-mel php /home/xxxx/public_html/stats/misc/cron/archive.php – url=http://xxxx.com.au/stats/

Here is some of the email body:
Using this ‘archive.php’ script is no longer recommended.
Please use ‘/path/to/php /home/xxxx/public_html/stats/console core:archive --url=http://xxxx.com.au/stats/’ instead.
To get help use '/path/to/php /home/xxxx/public_html/stats/console core:archive --help’
See also: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

If you cannot use the console because it requires CLI
try ‘php archive.php --url=http://your.piwik/path’

I have no idea why these emails are sent to me from Piwik, but it would be nice to stop them as I have to delete them every month.

Any help greatly appreciated.
Thanks, Nick


(James) #2

Have you actually read the email?

Given the path you have for your Piwik install, I’m guessing you’re on a cPanel box which might explain as to why you aren’t setting it up via CLI. Do you have a jailed shell at all? Can you setup the new method of archiving data?


(Matthieu Aubry) #3

Hi there,

in our docs: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

the cron job command ends with:


> /home/example/piwik-archive.log

try to add this?


#4

Thanks for the suggestion, but I’d rather not play around with cron job - as I don’t know anything about it.
All I did to install PIWIK was follow the instructions - if it created a cron job during installation, then I have no idea - and it’s all beyond me.
I assume the problem is that it is e-mailing me to tell me there is a problem when it runs the cron job that it created - is that right?
Would unistalling and re-installing PIWIK remove the problem by updating its own files (cron job) during the reinstall?
Perhaps there is a way to fix the problem from the PIWIK admin?
Perhaps there is a way to have the emails sent once a day rather than once an hour?
Any help, greatly appreciated.
Thanks
Nick