Stop counting


(nerkn) #1

Hi,
I’ve installed and inserted code to content. I watched and used the Ui. But after working say 10 minutes. It havent been working for 8 hours or more. I checked the js code I’ve inserted, also ui is working (it shows as if there is no visitors for 8 hours)


(vipsoft) #2

Check date.timezone in php.ini. If not set, it defaults to America/NewYork (EST).


(nerkn) #3

at 10 o’clock in the morning I see 10 people! after a while at 11 I see nobody is roaming inside my site. But it is impossible, I see online people. Then now it is 6pm (18) It’s been 8 hours but it is reported that 10 people had been in my site. While google analytics shows 558 people for today.
It is normal to have 558 people, cause my site gets nearly thousand hits per day. 10 visitors is not logical.
Perhaps I activated a plugin causing error to record?


(nerkn) #4

Now I activated : DBStats. When I navigate to /index.php?module=DBStats&action=index&idSite=1&period=day&date=yesterday

It shows only this error:
Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘?’ at line 1


(vipsoft) #5

If there is a mismatch between your MySQL server timezone and PHP timezone, there’ll be a lag in reporting or an SQL error when processing archives.

Yours appears to be the latter case. Please check php.ini’s date.timezone is correctly set.


(nerkn) #6

I couldn’t find any resource for changing timezone.
But I’ve solved my issue. I changed the date of piwik’s reporting time. I cant understand how yesterdays records created.

I’m sorry messing for the mess.


(Dukessa) #7

I got this problem too.
It’s kinda confusing.

I kept seeing the same visitors for a whole day… it didn’t make any sense.
Is there a way to fix this kind of lag once for all from admin settings or something?

Thank you!