Stats not building


(Curu) #1

Hello, I tried to update to 0.6.4 automatically, the update went fine, but the stats no longer build themselves.
The page loads and I get 'Oups ! Problème rencontré durant la requête, veuillez réessayer.'
I thought the update was somehow corrupted, so I installed piwik from scratch and still got the same issue.
I emptied tmp/asset/, but that didn’t solve anything.
Anyone got an idea?
Thanks a lot


(Matthieu Aubry) #2

When you load the dashboard once, do you see files built in tmp/assets/ ?

If you delete them and refresh the dashboard, do you see newly created files in there?

If you refresh again 5 minutes later, do you see updated timestamp on these files are they unchanged, as expected?


(Curu) #3

Yes, the files re-create themselves after deletion and the timestamps don’t seem to change.


(Matthieu Aubry) #4

did you try to setup auto archiving: http://piwik.org/docs/setup-auto-archiving/


(Curu) #5

I tried some time ago I couldn’t make it work, so no.


(Matthieu Aubry) #6

please PMthe bug description, piwik URL and pwd, and possibly FTP pwds. I’ll take a look thx.


(duxnrunz) #7

I’ve just upgraded and I think I’ve got the same issue. Dashboard is empty and the add widgets link is not working. I’m happy PMing my details if it will help


(Curu) #8

Hum that’s strange, I copied the datas on another directory of my server, linked to another domain to which the piwik original database is linked and the stats build just fine.
Was there any change between the two versions that would not permit anymore to connect to another db (still on localhost though)?


(Curu) #9

Is your piwik db located on the same one that the domain you’re using to call piwik or on another one?


(duxnrunz) #10

Yeah the db is on the same server


(duxnrunz) #11

To clarify I’ve got a reseller account and the sites I’m tracking and Piwik are on the same server but under different domains.


(Curu) #12

I meant :
you call piwik by XXX Sex - Free Porn Movies - Porno Videos on XXX.com does xxx.com use the same db as piwik or another one?
In my case I use another one.


(Curu) #13

Same as I, perhaps it comes from there.
Can you try to copy piwik’s datas on a domain that directly links to piwik’s db?
That worked for me (I created a dummy domain on my server for that)


(duxnrunz) #14

where do i find “piwik’s datas” ? thanks.


(duxnrunz) #15

Just to mention, with mine, it’s just the dashboard that’s not loading the other pages load fine


(Curu) #16

By piwik’s datas, I meant the content of piwik’s directory.
But in my case nothing’s working anymore, not only the dashboard.


(Curu) #17

Solution:
chmod 755 on tmp/assets and its content and everything’s back in order.


(duxnrunz) #18

Thanks Curu, but that didn’t work for me


(crudi) #19

I’ve got the same problem and the tmp/assets folder already has the necessary 755 rights.

Only the Dashboard makes trouble - nothing else.


(Matthieu Aubry) #20

Hello

Maybe this is the same bug as http://dev.piwik.org/trac/ticket/1497 ??
Do you see javascript errors? If you do, check out the fix in the ticket: http://dev.piwik.org/trac/ticket/1497#comment:14