Static assets not loading in Chrome

Hi community,

I installed Matomo on my Nginx server and used the Nginx config provided by Matomo to set up the host. When I visit the login page for the Matomo dashboard, all static assets are being blocked by Chrome. If I open the same page in incognito mode or another browser, all works fine.

I’m running another Matomo installation with Apache and there are no problem like this.

How can I fix that issue?

Are these assets on the same domain? on the same protocol (HTTP vs HTTPS) ?

Yes, all requests are on the same domain with HTTPS. When I try to open these blocked assets in a new tab, they are loading perfectly without any errors.

“blocked” sounds a lot as if some browser extension is telling the browser to not make those requests.
Is it possible that you have an adblocker or something like this enabled with an overly wide rule that matches those requests?

Maybe it’s a default setting from Chrome. But I don’t have installed anything manually.

On another server, I have running another Matomo installation with Matomo version 4.4.1 and Apache as web server. This installation is running without any problem in the same browser.

As the issue can already be reproduced on the login page, can you maybe send me the URL as a direct message?

At least for me with Chromium 93.0.4577.82 (and a fresh browser profile) everything is loading fine. So there has to be something in your Chrome setup (or maybe you have another software like an anti-virus or a company firewall intercepting and blocking the request).

Ok, thank you for that information. Then the problem is caused by my personal browser and not the server config.

I only have the issue on Matomo installation on version 4.5.0. Older version doesn’t have this issue.

Are there any significant changes in 4.5.0, that could cause that?