[SOLVED] White Screen of Death, but piwik.js and other files loading


#1

I am getting a White Screen when trying to reach the Piwik admin login, however it appears that the tracking files are loading fine on the sites being tracked. Also if I click back to my history and go to the URL for a report page I get an Piwik “Not Logged In” error page. I checked out logs and these are the two errors in the server logs


[Mon Jan 05 15:03:33 2015] [error] PHP Fatal error:  Call to undefined function mb_internal_encoding() in /data/web/wbtrack/libs/MaxMindGeoIP/geoipcity.inc on line 130
[Mon Jan 05 15:14:13 2015] [error] File does not exist: /data/web/wbtrack/https:

Not sure what they mean. Any help is appreciated.

Thanks
-Rob


(Matthieu Aubry) #2

Hi Rob, thanks for the report. Could you paste this into a bug report at: Issues · matomo-org/piwik · GitHub

This looks like a bug in the Maxmind library we use. we can fix it and submit the improvement to them upstream. it will help that you create the issue so we follow up!


#3

Okay. Is that what’s causing the white screen, any idea how to resolve it? I should have mentioned I’m running on version 1.12…would updating help to fix this issue?

-Rob


(Matthieu Aubry) #4

White screen of death is explained in this FAQ: I get 'Oops... there was a problem during the request.' or 'Internal Server Error' or '500 error' or the 'White screen of death'. How do I proceed? - Analytics Platform - Matomo


#5

I think I’m at step 4 of that FAQ…‘please ask in the forums’. The errors I have in the initial post are the only ones I found in the error log (none of them seem significant to me) and I’m not sure where else to look. I should also mention that while I have a white screen of death, I’m able to interact with Piwik through the API (I just successfully added a few sites)

Thanks
-Rob


#6

Same as Rob, Piwik appears to be functioning, adding data in my wordpress dashboard, but I cannot access the administrative interface and data for piwik. I see what is described as “white screen of death” when i try to access Sign in - Piwik.

I have searched my server error logs and piwik does not appear there.

Another website, with separate piwik install, running from same host, is displaying piwik admin interface normally.

Thanks for your help!

Violet


#7

Latest News: Still getting a whitescreen :S, but the API and file-serving seems to be functioning fine. Upon restarting the server/apache things seem to be working for a short time <15min before the whitescreen comes back


#8

After much poking and prodding it looks like I have resolved my issue. I cleared out all files in ‘tmp/templates_c’ and refreshed the login screen and everything worked again.

Thanks!
-Rob


(Matthieu Aubry) #9

Maybe you can try using our latest 2.11.0 beta: http://builds.piwik.org/
or see: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo


#10

I probably should since deleting those files only seems to get things working temporarily (login.tpl.php is an empty file)

Getting Piwik up to date is next on my list.

Thanks
-Rob