[Solved] White page after upgrading Piwik from 1.11 to 1.12


I’ve recently upgraded from 1.11 to 1.12 and now Piwik shows a white page:
[attachment 1305 piwik_white_page.png]

I’ve followed the FAQ solutions and nothing worked, except checking web server error logs, I’m not sure where to find them (I’m under Ubuntu Server 10.04). I have also removed all piwik files and uploaded again (a lot of times) and it doesn’t work. Don’t know if it could be a hint but Piwik is taking its time loading the page, about 35 seconds (I’m using an old pc as a server, but it is taking 35 seconds!!)

Any hint why it is happening?


Chcek the logs under /var/log/httpd and see if you can find anything

I’ve found this on apache2 error.log:
PHP Fatal error: Maximum execution time of 30 seconds exceeded in piwik/libs/jsmin/jsmin.php on line 136, referer: piwik/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday

Also, when I removed all piwik files and uploaded again, Piwik showed an error which states that the size of some language files were not the expected and I had to upload them as binary files.

Well that’s the problem, try uping your maximum execution time in your php.ini

If you look for max_execution_time = 30 in your php.ini file you should be able to change it there (Remember to reload your apache instance after changing it)

Thanks a lot, it worked!

I’m wondering what Piwik was doing to take more than 30 seconds, I guess it was to initialize and configure. Now it seems to work properly.

Could have been more SQL queries or just generating the new reports.

Anyway, glad it worked!

Probably what takes so long is to “MERGE” all Javascript and CSS file together in one big file for improved UI performance