[solved] Update to 1.10.1 - directory issues

After updating to 1.10.1 I get the following:

Piwik couldn’t write to some directories.

Try to Execute the following commands on your server, to allow Write access on these directories:

chown -R www-data:www-data /home/rs/public_html/track
chmod -R 0755 /home/rs/public_html/track/tmp
chmod -R 0755 /home/rs/public_html/track/tmp/templates_c/
chmod -R 0755 /home/rs/public_html/track/tmp/cache/
chmod -R 0755 /home/rs/public_html/track/tmp/assets/
chmod -R 0755 /home/rs/public_html/track/tmp/tcpdf/

However, nothing I can do seems to fix it. I have followed those instructions both via SSH as well as my FTP client. Nothing changes :frowning: I even tried creating and installing it in another directory. No difference at all.

I’ve been trying to fix this for a long time and finally decided I needed some help :frowning:

I hope someone else has seen this and fixed it.


what user are you assigning as owner?

I assigned the root user as the owner.

what if you assign apache or www-data as owners?

I don’t seem to have a www-data user, but tried apache with no success.

there were a bunch of errors with the search engine PNGs when assiging that user, though. Essentially all of this format:

chown: changing ownership of ‘/home/rs/public_html/sensitrack/ptrack/plugins/Referers/searchEngines/www.search.ch.png’ : Operation not permitted

I’m guessing that is happening for all PNGs in that directory

how did you uload? Which ftp client did you use?

I used WS_FTP. Same I have always used to update Piwik without problems for years :slight_smile:

can you copy the exact chown command you use for this instance? Im curious to see the structure of it. What unix flavour you running?

The server OS is: CentOS 5.9

I’ve never had to do the chown command before for Piwik… always just worked (did have to change permissions to 755 on some directories, though)

Here is the chown command:

chown -r apache /home/rs/public_html/sensitrack/ptrack

Hi i think you need just one little tweak

chown -R apache /home/rs/public_html/sensitrack/ptrack

Give that a try

sorry, the R was capitalized. I hit the up arrow to be sure of that, but it was.

the group of folders giving you an issue.

chmod -R 0755 /home/rs/public_html/track/tmp


chmod -R 777 /home/rs/public_html/track/tmp

see if that help

add the -v to give you verbose results in case there is an error

I get a bunch of errors with that one… I used the following command:

chmod -Rv 777 /home/rs/public_html/sensitrack/ptrack/tmp

I got the following (recursive through the directories):

chmod: changing permisssions of ‘/home/rs/public_html/sensitrack/ptrack/tmp’: Operation not permitted
failed to change mode of ‘/home/rs/public_html/sensitrack/ptrack/tmp’ to 077 (rwxrwxrwx)

Then followed through to: /assets/, /tcpdf/, /cache/, /templates_c/

ok maybe just sudo the commands again teh -v to show if any errors.

sudo chown -R apache /home/rs/public_html/sensitrack/ptrack

ok, I’m going beyond my expertise here… but gave it a try :slight_smile:

I got the following:

rs is not in the sudoers file. This incident will be reported

(rs is the user)

if you type


does it ask for a password? If so enter it and then run

chown -R apache /home/rs/public_html/sensitrack/ptrack

etc others

The sudo command asked for a password, but not this one.

sudo said:

We trust you have received the usual lecture from the local system administrator. it usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

Then I had to type in the password :slight_smile:

Using the su command, I got:

-bash: /bin/su: Permission denied

odd i would have thought either way you could run commnads as root.

Which isp is this maybe a tech needs to help you here.

I think I am not as root… I think I did login the last time with the rs user (non-root). Let me try to re-login to ssh

My bad… I was site root, but not server root (probably doesn’t make sense, i guess)… I’m a windows user mostly :slight_smile:

ok, so that command worked (SU, then chown), but nothing has changed.