[Solved] Create/copy error not going away


#1

I had to move our Matomo installation to a new server. While it was not as easy as described in the docs, I got it working except for one minor thing. This one error message keeps popping up:

Error while creating/copying file to /path/to/matomo/plugins//IP2Location/API.php .
Please check that the web server has enough permission to write to these files/directories:
For example, on a GNU/Linux server if your Apache httpd user is www-data, you can try to execute:
chown -R www-data:www-data /path/to/matomo
chmod -R 0755 path/to/matomo

(1) Yes, the error message shows two slashes between “plugins” and “IP2Location”.
(2) Yes, I have run both commands successfully and checked that all files are changed accordingly. I even tried with 0775.
(3) I already cleared the cache by removing all contents from the tmp folder.
(4) I deactivated and uninstalled the plugin. Even then the message persists. Reinstalling and activating the plugin doesn’t help either.

…facepalm…

(5) I just logged out as admin and logged in again. The error message is gone.

Since I already wrote all of the above, I’ll post it anyways in case someone stumbles upon a similar issue.