[SoIved] fail to config pw-piwik when piwik on NAS behind firewall


#1

Hi!

I have WordPress blogg running on a ISP where I have installed the plugin wp-piwik.
I have a Synology NAS behind a firewall where I have installed piwik. The firewall redirect port 8030 to the NAS with port 80. I can reach piwik with the following url: mydomain.com:1224/piwik (both domain name and port number are other than the example). I can logon and see my piwik installation.
I see my auth token. Then I login to my WordPress installation and tries to configure piwik with the url and auth token. When I save config I get an error message saying I need to check my url or auth token.

Anyone who can see what I seem to do wrong here?

/Niklaslved:


#2

Here is the output from the test script on the support tab in wp-piwik:


*** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
Using: cURL
SSL peer verification: disabled
User Agent: WP-Piwik
Call: <mydomain.com>:/piwik/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
Result:

Time: 0s

*** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
Using: cURL
SSL peer verification: disabled
User Agent: WP-Piwik
Call: <mydomain.com>:/piwik/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2Fbredband.skarkind.se&format=XML&token_auth= + TOKEN
Result:

Time: 0s


Is it SSL peer verification that fails for me? How do I solve that?

The version of Piwik is 2.2 which is the latest you can run out of the box on Synology.


(Matthieu Aubry) #3

The version of Piwik is 2.2 which is the latest you can run out of the box on Synology.

Is the latest version 2.5.0 not working on Synology? why?


#4

Problem solved. The port number that I used from WordPress to my firewall (8030) was closed by my ISP that hosts the WordPress server. The port 8080 was open and when I used that one it worked directly.
It was I who did not understand how the ISP’s firewall was configured.

With normal update procedure I only get Piwik 2.2 and not the 2.5. At least not yet.