Slow loading time


#1

Hi,

I have slow loading time from my site: https://powersolutions.pl/

When i load firebug it says it takes 10 seconds to load piwik.php script.

It’s to much.

What may be wrong?


(Matthieu Aubry) #2

Can you try disable the Provider plugin in Settings > Plugins ?


#3

Yes, i tried. What is the job of this plugin?


(Matthieu Aubry) #4

Tp create the Location > Provider report (it does a reverse DNS lookup which can be slow)


#5

Hello,
I have near the same problem:

  • The fist time pikiwik.php takes about 7 to 9 seconds
  • After that, it’s take about 0.3 to 0.5 second

I have disabled Provider Plugin, but the problem is still there.
What can I do to solve the problem ?


(Matthieu Aubry) #6

The first time is because it runs the Scheduled Tasks, which take some time (once per hour, or once per day). You can disable this by setting up auto archiving: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


#7

Hello,
I have disabled auto archiving, and now loading time is always short.
The problem is solved
Thanks a lot


#8

matt,

I have noticed the same issue. I don’t understand why the action proposed in msg-115711 above would resolve the issue - I thought Scheduled Tasks (I assume that is the same as the Piwik trigger for archiving (referred to here How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ) were only run when the Piwik user is pulling up the dashboard / reports.

Why would this affect an ordinary visitor to the site being monitored?

Thanks.


(Matthieu Aubry) #9

Why would this affect an ordinary visitor to the site being monitored?

If you don’t setup the cron, then Piwik tries to process statistics automatically (before you visit Piwik, so that it willload fast). it does that by triggering the archiving from an actual visit on the website.