Slow after upgrading to 2.03


#1

So we have been using Piwik for a little over a year now. Never had any issues, everything was fast, and ran great.

Had a small hiccup during the upgrade but was able to make it through. After the upgrade was complete I noticed it was a bit sliggush on the main panel. Changing to monthly stats would completely die out initially due to execution time exceeded.

I went ahead and upgraded to latest beta but it is still very sluggish compared to version 1

We are running standard Cpanel Centos 6.4, Apache 2.2.26, PHP5.4.25


(Matthieu Aubry) #2

Setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


#3

Yep did that after I posted above. Although I am getting errors when the cron runs:

INIT
Querying Piwik API at: Index of /analytics
Running Piwik 2.1-rc8 as Super User: dkent
ERROR: Got invalid response from API request: Index of /analytics. The response was empty. This usually means a server error. This solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. Please check your Web server Error Log file for more details.
ERROR: The Piwik URL Index of /analytics does not seem to be pointing to a Piwik server. Response was ‘’.

php memory is at 512 already and I have already rechecked the cron line.

/usr/bin/php5 /home/bluerayc/public_html/analytics/misc/cron/archive.php --url=http://bluerayconcepts.com/analytics/ > /home/bluerayc/public_html/analytics/misc/log-analytics/piwik-archive.log

-f doesnt work so i removed it.


(Matthieu Aubry) #4

Please try with 2.1 RC as we have much improved this part 301 Moved Permanently


#5

Already did currently on RC8


#6

you arent using suhosin memory control are you?

how did you specify the memory in php.ini can you paste the setting of just memory definition to review?


#7

No on the memory control

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 45
max_input_time = 60
memory_limit = 512M


#8

ok looks good is it possible the master php values are being used thus a lower value is actually used?

do you have any htaccess files in the piwik folder that could be hindring the mem setting?


#9

htaccess and account level php were the first things I looked for. THere is no account level php.ini and the htaccess files do not contain any memory lines.

the memory definition I post was from the server php.ini.


#10

what python version is being used any caching like nginx?


#11

Just found another issue. Once i setup the cron job (that still didn’t work) all my data from the time i started running the cron is gone. Real time visitors data is showing accurately, but nothing else

As a test I went into general settings and Changed “Allow Piwik archiving to trigger when reports are viewed from the browser” back to yes. All my data showed back up. I am presuming that because the archiving cron job is not working the data was not showing.