SiteManager Module


#1

Hi,
I’ve been using Piwik for sometime and have regularly upgraded whenever I’ve been notified of a new release. Since shortly after the release of Piwik 2.0 I’ve noticed that the ‘Manage Websites’ page under ‘Settings’ does not work. My ‘Piwik’ does attempt to do something but I end up getting my site’s 404 page with a ghosted overlay of some of the menus.

I was hoping that it would just get sorted out and one of the recent change-logs did look promising but its still broken. I’ve even tried a fresh install (last week) but still nothing. Could I have some advice on how to fix this? Also, how did it happen, is it something my end that I should look out for?

My php log reads:


Error in Piwik: The plugin SiteManager is not enabled. You can activate the plugin on Settings > Plugins page in Piwik.

But the plug-in is not in the list. I know how to adjust the settings and add sites using the database but would ideally like this sorted.
Any help would be most appreciated,
Ben


(Matthieu Aubry) #2

in Piwik > Settings > Plugins enable the plugin SiteManager.

make sure you use at least piwik 2.7.0


#3

Hi Matt,
Thank you for your quick reply!

I’m very sorry, I should have said I tried the obvious… I’m currently using the latest version of Piwik as the super user (the only user on my system) and I don’t have the Plugin listed. All the Plugins are enabled except the ‘example’ ones. How can I get the Plugin?

Cheers,
Ben


(Matthieu Aubry) #4

can you try again to re-upload all files from piwik 2.7.0 from fresh download from Index of / ?


#5

Hi Matt,
I’ve just tried putting a fresh version on (copying the files) as suggested. The problem still exists :frowning:

I was wondering would it have anything to do with ‘plurals’? In the plugins folder there is a ‘SitesManager’ folder yet the php log refers to ‘SiteManager’?
Do I need to add or remove an ‘s’ from something? A simple rename of the folder in plugins to ‘SiteManager’ didn’t work.

Cheers,
Ben


(Matthieu Aubry) #6

Good point! I cannot find any mention of SiteManager in PIwik. Maybe you added manually SiteManager to your config file?


#7

Hi Matt,
It’s nothing I’ve added -since yesterday I copied over the files from 2.7 and the problem still exists (basically a fresh install without clearing the database).

Previously I’ve used Piwik from about 1.2 and have just upgraded every time using the button when ever a new release is available. I think the issues with the ‘Manage Website’ page came about around version 2.3 or 2.4. I’ve checked the config.ini.php and the plugin ‘SitesManager’ is listed so it must be missing an ‘s’ somewhere else.

Cheers,
Ben


(Matthieu Aubry) #8

if you have access to the console can you go in the piwik directory and type


rgrep 'SiteManager' .

this will find all places where SiteManager without s is found. anything found?


#9

Hi Matt,
Many thanks for your reply and I really appreciate your help on this one!

Unfortunately my host doesn’t allow that command but I downloaded my piwik folder as well as the database dump and used an editor to search all the files for the term ‘SiteManager’… nothing came up. Since putting the clean version of 2.7 on the system, I no longer get the error line in my php log though the problem still exists. Maybe we’re barking up the wrong tree with the Site(s)Manager thing.

I’ve attached a screen shot of what happens when I try to visit the manage websites page in Piwik. It looks like only part fails as the menu etc. are place on-top of a bad version of my 404 page.

Any other ideas?
Cheers,
Ben