Site Search is not working in Matomo

Hello, We have Matomo environment running on 3.14.1, MySQL-8.0.23, php - 7.4. We have configured websites & enabled Site search option also from settings. But still it is not showing data in the dashborad.
Can some one help on this ?

Thanks & Regards

Which browser did you use to test the tracking?

During tracking, is there no JavaScript error (see in browser developer tool console)?

Is there also no HTTP error (see in browser developer tool network tab)?

On some browser, a DNT HTTP parameter is sent (and on some browsers it can’t be disabled) and Matomo don’t track them by default:

Finally, you can try to debug the tracking server side:

Hello philippe,
Thanks for the support,
We tried to check all the scenarios, updating the results below.

  1. Browser : Google Chrome - Version 96.0.4664.45
  2. Checked developer tools - no errors updating screen shots.
  3. Enabled do not track
  4. Enabled debug logs also from server but still no errors.

I just want to highlight some points here, last time when we try to test it we just enabled “site search tracking & added some key parameters” the it worked for one of the testing website. But the same configuration is not working for some production websites. We are not sure why ? if it is browser issues it might not work for testing website right? i am sharing both working & issue screen shots as well.

Thanks & Regards


On your network tab, I don’t see anything about Matomo…
Also, is it possible for you to migrate to the version 4.x of Matomo?

Hi Philip,

We are sharing again screen shots of network tab along with Matomo details. Yes we will do that but not immediately. We are planning to do it by next year. Mean while users are reporting this issue.
Let us know if any inputs needed.

Thanks & Regards