Since today no tracking on all websites


(ocicep) #1

Hi,

befor 3 days i do updated 0.6.3 successful and every think was ok. But since today no tracking anymore on all my websites and i do no changes.
How can i resolve this problem?

Thanks…


(cout12) #2

I have the same exact problem. Since today all my websites show 0 traffic which is obviously not the case

Whats going on?


(barbonister) #3

Same here!
Since last night all my statistics are 0. But suddenly 2 visits appeared for one of the sites. In last 4 hours style_emoticons/<#EMO_DIR#>/blink.gif

It’s 0.6.3


(mutor) #4

Same problem here … I even tried to make a fresh install to piwik - didn’t help. I am suspecting that the problem is that the tracking URL structure (query string after piwik.php) has changed slightly with the new version (0.6.3) and many hosts don’t allow to have an URL as query string variable because of security reasons (injecting malicious code from external websites).

Would love to get a solution as soon as possible (I think excluding “http://” from the url= parameter in query string would do the trick).


(vipsoft) #5

The url is encoded … that aspect of piwik.js hasn’t changed.

Depending on what version of Piwik you updated from, you may have to have to go to the Sites Manager and configure the timezone for each of your sites being tracked.

Depending on what plugins you have installed, number of sites, number of visits, etc you may have to increase the amount of memory available to php. Refer to the memory_limit in php.ini or via phpinfo().

In any case, please look at your web server logs to see if there are any errors being reported. The same symptom (no visits) may have different root causes.


(mutor) #6

Well the error appeared right after upgrading to 0.6.3 version of the piwik. When I monitor the headers, then it is clearly visible that the following url gets HTTP/1.1 403 Forbidden message:

h-t-t-p://www.mysite.com/piwik/piwik.php?idsite=1&rec=1&url=http%3A%2F%2Fwww.mysite.com%2F&res=1024x768&h=18&m=16&s=15&cookie=1&urlref=&rand=0.1559303441799481&pdf=1&qt=1&realp=0&wma=1&dir=0&fla=1&java=1&gears=0&ag=1&action_name=MySite.com%20-%20Test%20and%20Test%20Title%20Ofthepage

but when I remove even a single letter from the query string url= parameter, like url=htp://… then access is not denied anymore and I get 200 code response. So it’s still all pointing to the fact that full urls (encoded or not) are not allowed by the host.

If the 0.6.3 didn’t change anything in the query string structure, I’m pretty clueless what to do. I will use some alternative till the bug gets fixed, because I’m missing all the tracking data for all my websites atm.


(Jacky102) #7

Hi,

I have the same problem with 2 of my site hosted on hostgator (different insttallation). I’d love to have the solution for my sites.

Thank,


(vipsoft) #8

It sounds like something coincidental with other changes on your web host.

Ask your hosting provider if they use mod_security or changed the filtering rules.


(vipsoft) #9

I can confirm that HostGator deployed changes to their mod_security rules on/around July 1st affecting a number of applications including Piwik on shared/reseller accounts. They are fixing this on a case-by-case basis, so open a ticket with your hosting provider if this is the case.


(mutor) #10

Yes, got this mod_security rule fixed (whitelisted) for me by Hostgator and Piwik seems to be working fine now. Thanks!


(ocicep) #11

Greate it works… i report this problem hostgator and the problem was resolved style_emoticons/<#EMO_DIR#>/smile.gif

thanks


(Matthieu Aubry) #12

Maybe Hostgator users could suggest to support that all users using Piwik could automatically have this removed?


(vipsoft) #13

Sadly, I don’t think HG quite groks security. They still have register_globals=on as the default.


(apedic) #14

hi all, i don’t know if i have your same problem, but i’ve 0 visits for a site while in the db i’ve 2665 records for that day. i’ve already posted a new topic, but no answer received style_emoticons/<#EMO_DIR#>/sad.gif

what can be the problem?


(TMG) #15

Thanks for posting this - I had the exact same problem (hostgator as well.) Of course, I am currently listening to the nice lady telling me what number in the queue I am, and wondering why on hold music always has a saxephone?

TMG


(optimum) #16

I have no reported stats after July 1st. So, I’d suspect HostGator would be behind this issue, in light of your comment. What specifically do I tell Hostgator when I open a ticket?


(vipsoft) #17

Open a support ticket. Tell them the mod_security changes are a problem. Give them a list of domains to whitelist.