Setup auto archiving of reports is not working (Windows)


#1

Following the “Windows: How to setup auto archiving using Windows Scheduler?”, I added the task showed in the attachment picture, and it is set to be executed every hour.
then I changed the general setting:
•Allow Piwik archiving to trigger when reports are viewed from the browser: No
•Reports for today will be processed at most every: 3600 seconds

But it does not work, the last visit graph showed the visitor is zero.
I do not know what was wrong,and how can I do it ?
and what dose the sentence of "In the task settings, you should input the path to the php.exe file and then the file to the misc/cron/archive.php Piwik archiving script. For example, "C:\xampp\php\php.exe “D:\www\piwik\misc\cron\archive.php”"means in the instructions for Windows users with the Powershell script.

I am looking forward for your help,Thank you very much!!


(Matthieu Aubry) #2

See this example http://piwik.org/wp-content/uploads/2008/11/piwik-archiving-scheduled-task-windows.png


#3

I had followed the example changed my piwik scheduler:
Run :E:\applicationsoftware\php\PHP\php.exe E:\applicationsoftware\php\wwwroot\piwik\misc\cron\archive.php
–url=http://202.0.0.0/piwik
Start:E:\applicationsoftware\php\

But It has error,like the attachments piciture. The last visit graph is still zero.
I don’t know what is wrong. Please help me! Thank you very much!!


#4

When I changed the piwik scheduler like this :
Run :E:\php\PHP\php.exe E:\php\wwwroot\piwik\misc\cron\archive.php
202.0.0.0/piwik
Start:E:\php\
the last visit graph is still zero.
The scheduler log %systemroot%/SchedLgU.Txt is not showing about this scheduler log.


(Matthieu Aubry) #5

Make sure your command line is something like:


C:\xampp\php\php.exe "D:\piwik\misc\cron\archive.php" --url=http://localhost/piwik/


#6

I am sorry, It is ashamed to ask you again.
I changed the task scheduler followed the " How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo", but it still has error, the last visit graph is still not changed.
The error picture is posted.

I installed the piwik in the windows operation system,following the guide to configure the piwik,and it works well when the visitors is under hundred people.
Dose there anything else need to do? Dose the api need to be configured?

thank you very much!!