setCustomUrl


(heinetz) #1

Hallo Forum,

ich habe heutemittag ein Update von 0.9 auf 1.5.1 gemacht und gucke mir jetzt (etwa 4 Stunden später) mal die
Auswirkungen an. Im Grunde sieht alles ganz ok aus. Jedoch scheinen meine customUrls nicht mehr richtig zu
funktionieren und daher gibt es Anpasungengbedarf.

Folgendes:

In der Darstellung unter Aktionen/Seiten, möglichst lesefreundlich zu gestalten, hatte ich damals herausgefunden,
wie mit:

setCustomUrl(Über Uns/Unsere Philosophie/Startseite)

… die URL:

/Ueber_Uns/Unsere_Philosophie/

… dargestellt wird. Das ganze hatte ich ‘einst’ mit Piwik 0.5.8 so konfiguriert und das war damals zwar eine Krücke, aber es funktionierte. Alle Aufrufe der URL werden seit dem Update als:

/Ueber_Uns/Unsere_Philosophie/Über Uns/Unsere Philosophie/Startseite

… getracked. Was natürlich unsinnig ist. Der Fehler ist offensichtlich. Es müsste natürlich (seit heute) heissen:

setCustomUrl(/Über Uns/Unsere Philosophie/Startseite)

… was auch funktioniert. Allerdings sind die falschen CustomUrls leider nach der Korrektur noch da. Daher frage ich mich grundsätzlich, ob da tatsächlich die von mir definierte CustomUrl in der Datenbank steht bzw. ob und wie ich diese falschen Einträge löschen kann.

Denn …

Weil in der aktuellen Version 1.5.1 die CustomUrl nicht nur an der, sondern auch an anderen Stellen und dazu als Link (der natürlich nicht funktioniert) auftaucht würde ich mittlerweile auf die CustomUrl verzichten und statt dessen mit setDocumentTitle arbeiten.

Allerdings würde ich ungern 2 Jahre Daten wegschmeissen und bei 0 anfangen um zu vermeiden.

bin für jeden Tipp dankbar

beste gruesse,
heinetz