Segmente / URLs stimmen nicht

Hallo,

habe Segment erstellt.

Seitenurl enthält “beispieltext-”

Möchte nur URLs filtern, die “beispieltext-” enthalten.

In der Ergebnisliste sind aber auch jede Menge URLs wie “kontakt” “Impressum” die den definierten String garantiert NICHT enthalten.

Was ist falsch?

Hallo,

Ich glaube das ist dasselbe Problem wie in https://github.com/matomo-org/matomo/issues/15438 und den dort verlinkten issues.

Das Problem ist, die Segmentierung läuft auf Besuchsebene. Nachdem man pro Besuch mehrere Seiten besucht, werden diese Seitenansichten auch ausgegeben.

Das Segmente filtert also so raus:
Wenn die Seitenurl A im Besuch ist, zeig alle Seiten vom Besuch an.
Es ist also kein klasischer Filter.
Den hätte man unten an der Tabelle - also als Suche.

Das lässt sich aktuell leider nicht lösen. Nur mittels dem Plugin Custom Reports - welches aber kostenpflichtig ist.

Hallo Thomas,

das ist sehr unbefriedigend. Wenn solche Basisaufgaben nicht sinnvoll bzw. nur kostenpflichtig erledigt werden, schmälert das die Motivation Matomo einzusetzen erheblich.

Nein, sehe ich nicht so. Matomo hat halt keinen solchen Filter, wie du es brauchst :wink:

Schauen wir uns diese Logik aber mal beim großen Konkurrenten aus den USA an.

Ich lege mal ein Segment an, in dem ich auf die Seiten-URL beschränke.

Das ist also vergleichbar mit dem Segment in Matomo, dass du wahrscheinlich so angelegt hast.

Wenn man sich nun unten das Ergebnis anschaut, kommt folgendes raus.

Also exakt der gleiche Aufbau, Logik oder Ausgabe wie in Matomo. Dann wäre also auch GA deiner Ansicht nicht, sehr unbefriedigend. Das ist häufig nicht so in der Wahrnehmung.

Um das Ergebnis zu bekommen, muss man in GA die Suche benutzen

und die ist in Matomo auch verfügbar.
grafik

Ich hoffe ich konnte dir helfen :wink:

Naja, in Analytics kann man sich schnell einen Filter anlegen über die Suchfunktion. Der liefert auch genau das, was ich will. Nämlich beispielsweise alle Seiten die mit /praefix- anfangen.

Wie geht das in Matomo in der Seitenansicht?
Segmente geht nicht.
Wie dann?

Oh mein Gott…
ganz unten ist das Suchfeld… was eine Usability… :frowning:

Habe es gefunden und das Ergebnis besser als mit dem Segment. Dennoch sind Seiten enthalten, die nicht da rein gehören. Dazu manche in schwarz und zusätzlich in blau … (Link) Warum?
Es ist eine Struktur die da ausgewertet werden soll. Entweder alles schwarz und blau oder nichts. Das ist nicht stimmig…

Es gibt in Matomo zwei Ansichten.

Hierarchisch - ähnlich dem Windows Explorer
Hier fasst er alle Seiten eines Verzeichnisses zusammen.
Schwarze Zeilen sind also Ordner :wink:

Flach
Hier zeigt er nur die URLs an. URLs sind in der Darstellung blau.

Ob du das Eine oder Andere möchtest kannst du in den Widget Eigenschaften umstellen.

Zahnrad anklicken … flach auswählen