Scheduled report send by "https://unknown/"


#1

Hi guys,

I’ll need your help on some Special topic.

We’ve setup Matomo 3.6.0 running on Windows Server, IIS, php 7.2.10 and MySQL 8.0.12.0
All is doing great so far!

But when sending scheduled reports those will have “send by https://unknown” in their body
and embedded pictures also target to h-t-t-p-s://unknown/<>/image.ext so that they cannot be shown.
We’re firing up the scheduler running the following command (–force for testing):
php.exe X:<>\Matomo\console core:run-scheduled-tasks --force --matomo-domain “h-t-t-p-s://matomo.contoso.com/”
When starting the email report from the users WebUI all links are fine!

In config.ini.php we have configured the following in regards of mail settings:
noreply_email_address = "matomo@contoso.com"
noreply_email_name = “Contoso Analytics”

Hopefully one of you can help me out with this “issue”.

Thanks and best regards
Chris