[Résolu] Certificat SSL auto-signé


#1

Bonjour,

Je viens de mettre en production une instance Piwik (version 2.3.0) sur un serveur Debian + Apache2 + MySQL.
Concernant les phases d’installation et de configuration, tout s’est parfaitement déroulé et Piwik semble opérationnel d’après le check-up système proposé au travers de l’interface web.

Jusqu’à maintenant, le dashboard ne me génère pas de statistiques et après avoir “retourné” l’ensemble des fichiers de logs de mon serveur, je ne vois pas de raisons “valables” expliquant ce manque de statistiques … sauf une :slight_smile:

En gros, j’ai installé Piwik sur un sous domaine de mon nom de domaine et pour corser un peu les choses, j’ai activé le sous domaine pointant vers Piwik en HTTPS. Jusque là, on pourrait se dire que tout est ok, mais comme je suis joueur, j’ai auto-signé mon certificat ^^
Pensez-vous que l’origine de mon problème se situerait ici ?

Merci d’avance pour vos retours, en attendant, je continue à enquêter de mon côté :slight_smile:

Et bravo aux admins/développeurs travaillant sur ce projet, vous faites du bon boulot comparé à AWstats !
Je n’aurais qu’une chose à dire : à mort Google Analytics xD

Amicalement,
Joël (aka cortexx)


(Matthieu Aubry) #2

Bonjour Joël

Donc vous avez importe les logs via le Log Analytics ?

apres avoir importe les logs il faut calculer les statistiques avec cette commande: Log Analytics tool - Analytics Platform - Matomo


#3

Bonjour,

Merci pour cette réponse :slight_smile:

Pour répondre à ta question, non, je n’ai pas importé les logs de mon serveur Web.
(même si je pense que je le ferais afin de “restaurer” l’historique des visites sur du long terme)

Là tout de suite, j’ai seulement installé Piwik et intégré le tracker sur mon blog.
L’instance Piwik pointe vers l’URL https://stats.domaine.fr et est paramétrée afin de suivre le nom de domaine http://www.domaine.fr.

Sauf que lorsque je compare les données de Google Analytics avec celles de Piwik pour la même journée j’obtiens le résultat suivant :

  • Google Analytics : Entre 250 et 300 visites uniques
  • Piwik : Moins de 10 visites uniques

Comme je l’ai précisé dans mon précédent poste, le nom de domaine pointant vers l’instance Piwik est en HTTPS avec un certificat SSL auto-signé.
Penses-tu que cela pourrait venir de là ?

Par exemple, si j’appelle l’url pointant vers le pixel utilisé pour contourner les bloqueurs de scripts : http://stats.domaine.fr/piwik.php?idsite=1, j’obtiens le message m’indiquant qu’il faut que j’ajoute une exception sur le certificat (chose qui est normale). Par contre, sans validation du certificat, l’image ne s’affiche pas et la visite n’est donc pas prise en compte.

Est-ce qu’il y a une option à activer dans Piwik pour la prise en compte du certificat non signé que je n’aurais pas vu ?!
Ou le problème vient-il d’ailleurs ?! (problème de configuration ou autre …)

Merci pour ton aide.
Joël


(Matthieu Aubry) #4

Pour que Piwik traque des pages en SSL HTTPS il faut que le certificat du serveur hebergant Piwik soit un certificat SSL valide.


#5

Salut Matt,

Merci pour ta réponse, j’avais lu ça dans la documentation en effet, d’où ma question qui était, est-il possible de “contouner” cette limitation ^^
Mais j’ai l’impression que ce n’est pas le cas … dommage :slight_smile:

J’ai donc réactiver mon Piwik sans SSL et le tout fonctionne parfaitement.
Je vais voir pour m’acheter un certificat, mais en prendre un en wildcard (ce qui m’intéresserait le plus) coûte une bonne centaine d’euros.
Le second plan serait d’en trouver un chez un fournisseur qui fournit des certificats “free” signés par une autorité de certification … à voir quoi.

Encore merci pour ton aide :slight_smile:


#6

Personnellement, je viens juste d’installer Piwik, j’ai un certificat ssl sur le site sur lequel est installé le panel de piwik, et un autre sur le site que j’analyse.
Les deux certificats ssl ont été créés gratuitement sur le site Startssl (désolé de la pub, mais ça peut en aider certains), et ce sont des certificats valides.


#7

Salut MZlemagicien,

J’ai fini par faire comme ça moi aussi :slight_smile:
Une génération de certificat “valide” chez StartSSL et HOP le tout fonctionne à merveille !
Je tentais de configurer un certificat auto-signé, mais Piwik n’apprécie pas trop pour le coup.
Je n’avais pas fait attention que c’était précisé dans la doc ^^

Encore merci pour ton retour !