Real time visitors working for all my websites but one

Hi everyone,

I have been struggling for a few hours and cannot find any similar issue here or elsewhere on the internet, so I am asking for your help !
(I am not a developer but I do have access to the Matomo files.)

I have Matomo 3.14.1 set up on 9 websites in total, 5 of them are Prestashop websites. For some reason, all of them are working just fine except for our main website (Prestashop) which does not show all the real time visits, but only a few of them from foreign countries…
I have used a Prestashop module to put the code in the websites, I have done exactly the same for all the websites, only changing the id number for each website. I am 100% sure the main website id has been set up correctly in the module.
I have tried the following :

  • Uninstall then reinstall the Prestashop module - did not work
  • In Matomo, delete my entry for the main website then create it again and updating with the new id in the Prestashop module - did not work
  • I have made an exact copy of our main website on our test environment, then create the entry in Matomo - It is working perfectly ! I cannot understand why the copy is working but not the original …
  • I have gone through the Matomo FAQ and tried a few things, but my competencies are limited, and nothing looked like my issue.

The result is always the same : for our main website, the real time visitors does not work. It still shows a few visitors from Germany though, but none from France (the website is in French and we know we have hundreds/thousands of visitors a day). For all the other websites, the real time visit will show within 3 seconds.

Do you have any idea why only one out of these 5 Prestashop websites is not working correctly ?

Thanks in advance,


Can you by chance send me a direct message with the URL to your main site?

Problem solved :
The issue was coming from the version of the module I used, so the Matomo code was not inserted in our main website.
I downloaded it from another source, installed it, and it started working.
I still do not know why it worked 4 out of 5 times, but I won’t quibble :slight_smile:

Big thanks to Lukas for identifying the root cause of this issue !

1 Like