Real-time Map not displaying


#1

Whenever I try to add the real-time map widget or view the visitors>real-time map page, the map does not display. Another user was getting an “object not found” error when trying to view the map. I went through the troubleshooting steps located here, but it’s still not working, even after overwriting the system files with a clean download of 1.11. Everything else seems to be working fine, including geolocation. Any ideas as to what’s going wrong?


(Matthieu Aubry) #2

Try: delete files in tmp/assets/*

delete browser cache

try again ?

is there any error in server logs ?


#3

I had a similar issue using IIS and it was caused by a 404 error on the SVG files. IIS won’t serve unknown file types and the type for SVG files (image/svg+xml) isn’t included by default.


#4

i try delete /tmp/assets/* not working.

I reinstalling piwik (same databases) not working :frowning:


(Matthieu Aubry) #5

post a screenshot ?


#6

Hi,

Thank you for your help.

My screenshot :


(Matthieu Aubry) #7

did you setup geolocation and does it detect the city / lat/long as expected? Geo Locate your visitors - Analytics Platform - Matomo


#8

Yes i use : GeoIP (PECL) or GeoIP (Module server HTTP), the result is same : no display in “real-time map visitor”.

But, in setting > Geolocalisation > Piwik say : D’après ce fournisseur, votre emplacement actuel est:
(46, 2)
France

Org: Inconnu* (unknow)
ISP: Inconnu

in english : About you’re supplier you’re geolocalisation is in france (46,2)

but not display :frowning:


#9

What browser and version are you using when you see this error?


#10

Google Chrome Version 26.0.1410.64 m


#11

Have you tried another browser? Firefox or Explorer?

What is the memory setting for php.ini?


#12

Yes i tried : Chrome, FireFox, IE.

Piwik run in Fast-CGI. (i use ISPConfig on the server)


#13

what is turn off fast cgi temporarily and use regular cgi to see if it helps


#14

CGI :
Forbidden
You don’t have permission to access /analytics/index.php on this server.


#15

after turning it back on could it be a folder permission error in piwik?

When you installed was it via shell install or a copy replace via ftp?


#16

when i change php setting to fast CGI, piwik work, but not real time map.

When i installed piwik (Update) i was renamed folder “analytics” => “Piwikold” and i was created a new folder “analytics” and upload by FTP the new files (sorry for my bad english i’m french)


#17

Pas probleme mon francais c est nest pas parfect…

is the url a https by chance?

is it a windows or unix server?

Is the geo ip green check mark in the admin section?


#18

Loool tu parles assez bien français :smiley:

I don’t use SSL for Piwik.

Linux server, with IPSConfig.

Yes all check mark is green


#19

Is there any web server error logs we could review?

what php version are you running?

Can you compare the user rights and permissions of your old install with the new? I wonder if some folder permissions are different…


#20

Hi,

Log error, i can feed i’m think, what’s log ? apache ?

Php version : PHP Version 5.3.3-7+squeeze14

I always piwik old folder, and when I use the real-time map does not work well.