Queued Tracking plugin not working fine

Hi experts!
I am using Queued Tracking plugin with Redis. Here is my test page on which tracking pixel is being executed fine. The request to Matomo showing 200 ok status code, but still I am not seeing tracking data in Matomo. Can anyone please help me if I am missing something?

Test Website: https://stitchology.me/test/example.html

From the above screenshots you can see the configuration of QueueTracking plugin and you can also see that it is working exactly fine.
But instead of showing tracking information it is still showing default first page which asks to add the tracking code first.

Any help will be appreciated! Thanks!

Matomo is set to keep things in the queue until you reach 25 requests, could that be the issue?

Hi @Naser_Aslam
Several info about QueueTracking.

  1. Do you have only one tracking server? (No load balancer?) If not (eg. you have 2 tracking servers), then you’ll have multiple queues (in my example 2x2queues = 4 queues)
  2. The track is not taken into account a long as one queue doesn’t reach its size. Then if you want to dequeue, put 1 as queue size and send a tracking request. Then queue is not adapted for
  3. Queue has yes one little problem: it doesn’t log in case of error (see below ticket). Then first try to check (without queue) if the tracking is working well alone.

I have manually refresh the test page more than 25 times on two different browsers and after few days still there is no visit log on the dashboard for this website.


Did you check there is no error in the tracking (by disabling the queue for a short time)?

There are lot of errors :frowning:
A dead lock occurs.

Error query: SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction In query: INSERT INTO matomo_log_link_visit_action (idvisit, idsite, idvisitor, idaction_url, idaction_url_ref, idaction_name_ref, server_time, idpageview, pageview_position, time_spent_ref_action, idaction_name) VALUES (?,?,?,?,?,?,?,?,?,?,?) Parameters: array (
Some more information generated by SHOW ENGINE INNODB STATUS\G; is given below.

*** (1) HOLDS THE LOCK(S):
RECORD LOCKS space id 279 page no 9289 n bits 288 index PRIMARY of table `matomo`.`matomo_log_hsr` trx id 7681918 lock_mode X locks rec but not gap
Record lock, heap no 210 PHYSICAL RECORD: n_fields 15; compact format; info bits 0
 0: len 4; hex 00367658; asc  6vX;;
 1: len 6; hex 00000075377e; asc    u7~;;
 2: len 7; hex 01000003a6048c; asc        ;;
 3: len 4; hex 0000004c; asc    L;;
 4: len 8; hex 000000000071563b; asc      qV;;;
 5: len 6; hex 42586d5a796b; asc BXmZyk;;
 6: len 6; hex 51463676534f; asc QF6vSO;;
 7: len 4; hex 000fb3d2; asc     ;;
 8: len 1; hex 81; asc  ;;
 9: len 5; hex 99ae9c74b3; asc    t ;;
 10: len 3; hex 019aeb; asc    ;;
 11: len 2; hex 0556; asc  V;;
 12: len 2; hex 0291; asc   ;;
 13: len 2; hex 03e8; asc   ;;
 14: len 2; hex 0322; asc  ";;

RECORD LOCKS space id 283 page no 140188 n bits 232 index PRIMARY of table `matomo`.`matomo_log_link_visit_action` trx id 7681918 lock_mode X insert intention waiting
Record lock, heap no 1 PHYSICAL RECORD: n_fields 1; compact format; info bits 0
 0: len 8; hex 73757072656d756d; asc supremum;;

TRANSACTION 351844404565568, ACTIVE 89 sec fetching rows
mysql tables in use 11, locked 11
LOCK WAIT 209360 lock struct(s), heap size 24404088, 24329330 row lock(s)
MySQL thread id 3838280, OS thread handle 70389417738336, query id 361837446 event_scheduler executing
INSERT INTO materialized_visitors_view (
        INET6_NTOA(mlv.location_ip) as ip_address,
                WHEN mlv.referer_type = 1 THEN 'Direct Entry'
                WHEN mlv.referer_type = 2 THEN 'Search Engine'
                WHEN mlv.referer_type = 3 THEN 'Website Refferal'
                WHEN mlv.referer_type = 6 THEN 'Campaign'
                ELSE 'YouTube/Media'
        END as referer_type,
        SEC_TO_TIME(mlv.visit_total_time) as visit_total_time,
        DATE(mllva.server_time) as server_time,
        MAX(sess_rec.ses_rec_link) as ses_rec_link,
        MAX(tmu_rec.tmu_rec_link) as tmu_rec_link,
        MAX(mllva.server_time) as se

*** (2) HOLDS THE LOCK(S):
RECORD LOCKS space id 283 page no 140188 n bits 232 index PRIMARY of table `matomo`.`matomo_log_link_visit_action` trx id 351844404565568 lock mode S
Record lock, heap no 1 PHYSICAL RECORD: n_fields 1; compact format; info bits 

Hi @heurteph-ei ,
After rebooting the database, the dead lock error is disappeared for short time, but when I run https://stitchology.me/test/example.html in the browser, the data is not tracked neither on chrome nor on firefox i.e., no visit information on Matomo. But when I run it in the Incognitio mode of chrome, the tracking is logged on Matomo. Why it is so?

Was the queue still active? (Most of the time, visits for the same user would be queued in the same queue, then maybe the queue of incognito user was full before the other one?)
Do you encounter some error in the browser console in case of “not-incognito mode”? Can you see the tracking in the network console of the browser?

Hi @heurteph-ei ,
Sorry to mention but I already disabled Queue tracking. And in that case I am facing this issue. Thanks!

Then, @Naser_Aslam again:

Hi @heurteph-ei,
Nope, there is no error in the console or network tab. You can look at the screenshot, all the requests show 200 ok status code.


In your screenshot, I don’t see any tracking request…

Hi @heurteph-ei,
What about tracker.php? Isn’t it a tracking request like matomo.js?

I would say ‘no’, because there is no HTTP param (site ID, etc.). I don’t know what this file is. The tracking target should be matomo.php.

Hi @heurteph-ei ,
We are using white label plugin. And it provides the facility to whitelabel the end-points. Please have a look at the following attached screenshot. Thanks!

I still don’t see any tracking request… tracker.php is a JavaScript file according to your console (the Matomo API probably).
No tracking request is sent to Matomo. Did you put tracking in the page?