Problems with server load


(piwiknewbie) #1

Hi,

I have tried using piwik this morning for about 3 hours. During that time, the webserver, which was specially set up on a dedicated server with the piwik mysql server (no more database access) recorded more than 400k hits.

Server hardware is a quad core xeon 5420, 2.5Ghz, 4GB RAM and a 4 disk RAID 10 SAS 15k rpm.

OS is Ubuntu server 9.04 and mysql is 5.0.77 using percona and google patches. I was using Cherokee web server 0.99.15 but i experienced the same situation last week using apache 2.2.

My worry is that after that 3 hours of running, server load was near 4.80 and had been growing slowly since i set up the server.

Are there any optimizations that i may have missed that could lower the server load? Anyone with experience in using piwik with that number of hits?

Any help will be appreciated.


(Blizzz) #2

On a friends root server (Ubuntu 9.04, Apache 2.2.11, MySQL 5.0.75 ) Piwik runs smoothly, i.e. there are no such problems. Did you check the running processes?


(piwiknewbie) #3

Yes, the server had been reinstalled from scratch the day before, and only the mysql server and httpd were running on it. Is your friend serving that number of hits?

Thanks for the feedback


(Blizzz) #4

[quote=piwiknewbie @ May 27 2009, 10:15 AM]Yes, the server had been reinstalled from scratch the day before, and only the mysql server and httpd were running on it. Is your friend serving that number of hits?

Thanks for the feedback[/quote]

Actually it’s my blog using Piwik on his server. However, there is not such a number of hits nor is the cpu load that high, just about 0.13.

Did you hits and cpu load reduce when you disabled piwik?


(piwiknewbie) #5

Yes, load went down to 0.00 in a progressive way as soon as i removed piwik from the pages being served and the visitors cache was replaced with the “clean” pages.


(vipsoft) #6

Have you looked at:

http://piwik.org/docs/setup-auto-archiving/


(piwiknewbie) #7

I had set auto archiving in crontab as the FAQ specifies, yes, and set the value to 1800 seconds instead of 3600, as it was only a load test with a few domains…