Problems with new install


#1

Brand new to Piwik. I just tried installing it several time on a shared server, each time I ran into the following errors:

After install, under the login block I see

[b]"A fatal error occurred

Please contact the system administrator, or login to Piwik to learn more."[/b]

When I try to login I get the following error and I am not logged in.

“Zend_Session is currently marked as read-only.”

After refreshing the page I am taken to my dashboard but many of the panels have the warning

“A fatal error occurred
The following error just broke Piwik (v2.5.0):
XCache: Cannot init
in Unknown line 0”

I have adjusted the .htaccess file with the following but the problem remains

php_flag xcache.cacher Off
php_flag xcache.size 0
php_flag xcache.stat Off

In piwik’s error log I see

[29-Aug-2014 14:30:01 UTC] Error in Piwik (tracker): Invalid idSite: ‘0’

In my server error log I see

2014-08-29 10:30:16.935 [NOTICE] [IP.IP.IP.IP:60795-0#APVH_domain.com] [STDERR] Error in Piwik: Session must be started before any output has been sent to the browser; output started in /path/analytics/plugins/Installation/Installation.php/95

Any suggestion?

Thanks


(Muhammed) #2

I do either face the same problem, no one here to help?


29 yo, Egyptian, FC Barcelona geek


#3

When you did the install, and before you tried to launch Piwik for the first time, did you correctly set the permissions of everything you uploaded to the server?

My server requires all directories and their contents to have 755 permission, except for the /tmp and the /config directories. These require 777 permission.


#4

Reinstalled with those permissions but had the same problem. Tried it on a different server and it worked fine. Guess maybe my htaccess file isn’t working on the server I need it on.


#5

I have found that for some shared hosting environments, it is actually faster and more reliable to do the installation or the upgrade manually.


(Matthieu Aubry) #6

Have you got opportunity to disable XCache ? Maybe it will help solve the issue.