Problems with auto archiving


(HellR) #1

Hi there,

I have set up the auto archiving with a crontab as explained here but the update only occurs every 2 hours…

I am running Debian Lenny, PHP 5.3.3 and MariaDB 5.1.49 with Piwik 0.9.9 and here is my parameters :

/etc/cron.d/piwik (the /data partition is mount with the noexec flag, so the sh command is needed) :

MAILTO=root
10 * * * * www-data sh /data/httpsdocs/webstats/misc/cron/archive.sh >/dev/null

/data/httpsdocs/webstats/config/config.ini.php (added on top) :

[General]
time_before_archive_considered_outdated = 3600
enable_browser_archiving_triggering = 0

I have set up Allow Piwik archiving to trigger when reports are viewed from the browser to No and Reports for today will be processed at most every to 3600 in the General Settings too.

As shown in the muning graph attached, the update is processed only every 2 hours (the execution at midnight was triggered manually).

Do you have any suggestion ?

Thanks style_emoticons/<#EMO_DIR#>/wink.gif


(HellR) #2

Solved by setting Reports for today will be processed at most every to 10 sec (Parameters and .ini file).