Problems with Archive via Cron


#1

Hello
Guys,

I´m facing a bit problem with Archive.sh
I´m trying to execute but I catch this error on my website 1


/app/prd1bea/Apache/htdocs/piwik/misc/cron/archive.sh
Starting Piwik reports archiving...


Archiving period = day for idsite = 1...
<?xml version="1.0" encoding="utf-8" ?>
<results>
        <result date="2011-04-27">28813</result>
        <result date="2011-04-28">29900</result>
        <result date="2011-04-29">27373</result>
        <result date="2011-04-30">4176</result>
        <result date="2011-05-01">1351</result>
        <result date="2011-05-02">22547</result>
        <result date="2011-05-03">26746</result>
        <result date="2011-05-04">26619</result>
        <result date="2011-05-05">26517</result>
        <result date="2011-05-06">25862</result>
        <result date="2011-05-07">7464</result>
        <result date="2011-05-08">2243</result>
        <result date="2011-05-09">26065</result>
        <result date="2011-05-10">27873</result>
        <result date="2011-05-11">28107</result>
        <result date="2011-05-12">27160</result>
        <result date="2011-05-13">25308</result>
        <result date="2011-05-14">7785</result>
        <result date="2011-05-15">2372</result>
        <result date="2011-05-16">26893</result>
        <result date="2011-05-17">26555</result>
        <result date="2011-05-18">26117</result>
        <result date="2011-05-19">26065</result>
        <result date="2011-05-20">25749</result>
        <result date="2011-05-21">7730</result>
        <result date="2011-05-22">2431</result>
        <result date="2011-05-23">27778</result>
        <result date="2011-05-24">26754</result>
        <result date="2011-05-25">27536</result>
        <result date="2011-05-26">27018</result>
        <result date="2011-05-27">26320</result>
        <result date="2011-05-28">7642</result>
        <result date="2011-05-29">2542</result>
        <result date="2011-05-30">29104</result>
        <result date="2011-05-31">28067</result>
        <result date="2011-06-01">26230</result>
        <result date="2011-06-02">25815</result>
        <result date="2011-06-03">25406</result>
        <result date="2011-06-04">6976</result>
        <result date="2011-06-05">2229</result>
        <result date="2011-06-06">26388</result>
        <result date="2011-06-07">26185</result>
        <result date="2011-06-08">25698</result>
        <result date="2011-06-09">26312</result>
        <result date="2011-06-10">25697</result>
        <result date="2011-06-11">7453</result>
        <result date="2011-06-12">2292</result>
        <result date="2011-06-13">27756</result>
        <result date="2011-06-14">26604</result>
        <result date="2011-06-15">26291</result>
        <result date="2011-06-16">25704</result>
        <result date="2011-06-17">352</result>
</results>/app/prd1bea/Apache/htdocs/piwik/misc/cron/archive.sh: line 73: 13901 Segmentation fault      $CMD

Has somebody faced this problem?


(Matthieu Aubry) #2

Segmentation fault == some kind of PHP issues, please upgrade your webserver and php and if not working, upgrade your mysql driver/PDO


#3

OK, Matt
I´ll try that!

My config of the piwik server is:


PHP 5.3.3 (cli) (built: Sep 16 2010 15:31:05)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

Apache:
Server version: Apache/2.2.11 (Unix)
Server built:   Sep 14 2010 20:22:32