Problems after trying to update

I was prompted to update but it gave an error and asked me to return to Piwik. When I returned I had a black dashboard but the update button was still there. I clicked on the update link, it told me I already had the latest version.

I tried to refresh and now it only gives me the top nav bar with nothing else on the page and takes a long time to load.


Can you check the Javascript Console and the PHP error log for errors? Do you remember what the error was?

There’s a lot of errors like this: Fatal error: Class ‘Piwik\Plugins\CoreHome\LoginWhitelist’ not found in /var/sites/j/ on line 224


Maybe try a manual upgrade as it seems like it failed:

I tried to do that by overwriting the files and loading the page but now I get this:

Warning: require(/var/sites/j/ failed to open stream: No such file or directory in /var/sites/j/ on line 70

Fatal error: require(): Failed opening required ‘/var/sites/j/’ (include_path=’/var/sites/j/’) in /var/sites/j/ on line 70

Forget my last comment. I got the files to upload but now it looks the same as before. If I click on settings. I get all this at the top:

Fatal error: Class ‘Piwik\Plugins\CoreHome\LoginWhitelist’ not found in /var/sites/j/ on line 224
A fatal error occurred

The following error just broke Piwik (v3.2.1):
Class ‘Piwik\Plugins\CoreHome\LoginWhitelist’ not found
/var/sites/j/ line 224


Thanks for making sure the files are correct:
I think it may be possible that the following change in the latest piwik version broke it:

Do you know how I can fix it? I’m desperate to get it working as this is my busy season and I need access to the analytics.

Good news. I managed to find the whitelist file and now it’s working.

1 Like


Great that you could solve it. Can you describe the solution a bit more in case someone comes across this post.