Problème avec le Rapport site par email


#1

Bonjour,

Je gère actuellement plusieurs sites à travers le piwik et un rapport de site par email est configuré par site web, un utilisateur est associé par site et n’a accès qu’au stastique de son site web.
Tout fonctionne correctement, l’utilisateur ne voit que ses stats etc…

A part le rapport par email qui affiche également le stat de visite des autres sites sur lesquel l’utilisateur n’a aucun droit.
Si je génère le rapport directement par le site web, ça fonctionne correctement pas de stats des autres sites. Ce n’est que le rapport automatique envoyé par email qui bug.

Merci pour votre aide

Version Piwik : 2.0.2

Laurent


(Matthieu Aubry) #2

Merci du rapport, je vais tester et confirmer. Jai cree un ticket avec priorite “majeure”. Users report for All websites in scheduled report · Issue #4471 · matomo-org/matomo · GitHub

N’hesitez pas si vous trouvez d’autres bugs dans Piwik ou suggestions, bonne année !


#3

Merci

Mes Meilleurs Vœux pour 2014.

Laurent


(Matthieu Aubry) #4

Corrigé dans 2.0.3!


#5

Merci je viens de faire la mise à jour, je vous tiens au courant.

Cordialement
Laurent


#6

Bonjour,

Je confirme le problème est résolé.
Merci beaucoup.

Cordialement
Laurent


#7

Bonjour,

J’ai également rencontré le problème après la mise à jour vers la version 2.0.2, mais malheureusement la mise à jour vers la 2.0.3 ne l’a pas résolu. L’envoi des rapports mail ne se fait toujours pas.

Merci de votre attention

B.


(Matthieu Aubry) #8

Le_villageois, voyez vous des erreurs dans le “error.log” du serveur web?

Avez vous installe le cron comme explique sur: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

Cela pourrait peut etre aider. Si vous l’installez et que les rapports se mettent a marcher, merci de me le dire ici, car il y aurait surement un BUG (les rapports sont senses marcher meme sans avoir installe le cron)


#9

Bonjour,

Merci pour votre réponse. Je ne trouve pas de error.log, je suis hébergé sur un serveur mutualisé où chaque site administré ainsi que piwik est dans un répertoire de public_html. Où puis-je trouver ce fichier error.log ?
Concernant le cron, je ne suis pas très à l’aise donc avant de créer la tâche j’ai une petite précision à vous demander.

la commande à passer :
/usr/local/bin/php -f /home/yourcpanelsitename/public_html/piwik/misc/cron/archive.php — url=example.org/piwik/ > /home/example/piwik-archive-output.log
Le fichier piwik-archive-output.log doit-il être créé avant ou sera-t-il créé lors du premier lancement de la commande ?

Sur mon hébergement, le répertoire qui contient piwik ne s’appelle pas piwik, celà peut-il avoir une conséquence sur l’envoi des rapports ? (je modifie bien-sûr la commande).

Merci de votre attention,

B.


(Matthieu Aubry) #10

le error.log est generalement disponible via le panel chez votre hebergeur.

Le fichier sera bien cree la premiere fois.


#11

Bonjour,

Avez-vous des news sur le problème des rapports qui ne sont plus envoyés ?

Attendre la 2.0.4 ?

Merci d’avance.


(Matthieu Aubry) #12

beta: Index of /