Problem with initial installation


I have created my database on my webhost and I believe that I have entered all of the requirements on the Database Setup page, but when I press the ‘Next’ button the next screen is blank. Checking the page with the page inspector I see the following:

‘Failed to load source … (Not Found) http://www…/matomo/’

I checked the Matomo folder and indeed there is no angular file.

So how to do I overcome this? Perhaps I have not filled out the fields correctly?

Any help with this would be much appreciated.


Greetings again,

I think I need to add some addiitonal information to my question.

I am using my actual webhost and not a virtul webhost. I have added the entire matomo folder to the site that I plan on tracking with the Matomo scripts.

That said, on the ‘Database Setup’ page I am using my actual 'Database Server" server IP. In addition, the prefixes to my database and tables is fixed - 'pabriles_ ’ - and cannot be changed.

Perhaps the Matomo code was expecting something different? I have followed the Matomo instructions as best I can, but now the server is denying access as follows:

Any help with this will be much appreciated.

Thank you!

I somehow managed to get Matomo installed last evening. This installation was not something I wish to do again.

That said, after installing the tracking script on my index.php and two other test webpages, this morning I learned that I had reveived 31 hits on these three webpages. I know that because I have set up a text message system whereby I receive a text whenever a user lands on these webpages. And, what did Matomo track - ZERO!! Since the installation process rewarded me with a ‘Congratulations!’, I was led to believe that the installation was done correctly and I would soon begin to receive tracking info. That has not happened.

I will leave the code on my webpages for another 24 hours or so. After that I will delete the dB and all of the code from my webpages.

There does not appear to be much traffic on this forum, but hopefully, I may still receive some help with this.


Which browser did you use tot test the tracking?

On some browser, a DNT HTTP parameter is sent (and on some brwsers it can’t be disabled) and Matomo don’t track them by default:

During tracking, is there no JavaScript error (see in browser developer tool console)?
Is there also no HTTP error (see in browser developer tool network tab)?

Finally, you can try to debug the tracking server side:

Hello Philippe,

Thank you for your advice.

Before I continue, I get this error message quite frequently:

To answer your questions:
My I use Safari. I did not see anything in my Safari Pref’s - Security, Privacy - that made reference to DNT parameters.

I have added the [Tracker] code suggested in the ‘Debugging the Tracker’ developer info webpage.

I have also tried to use both Chrome and FF and neither would accept my login cred’s for some reason.

As far as using the Developer inspection in Safari, the only Network or Source error I get is failure to load the favicon, which does not exist.

I hope that, with your help, we can get this tracking code to work because I am concerned about all of the traffic that this site receives. It has been up for over three years, but the daily traffic seems unreal to me. I discovered this when I began testing my text messaging PHP scripts. This is why I want to verify whether this traffic is actual or something worse.

I sincerely appreicate your help.

Can you read the error in the network tab of your browser developer tool?

About DNT, to be sure, you have to check the HTTP header or the requests:
In my case, DNT is set, and I can’t disable it. That’s why I suggest you can disable the use of DNT server side…

You previously wrote that you did not have traffic, but on your screenshot I see some…

Did you configure the arc hiving properly?


Thanks for getting back to me.

When that error message appeared I did not think to check with the developer tool. The next time that error appears I will do that.

Thank you for all of your suggestions and help, but I think something nefarious is causing the pings I am getting to my website. Recall that I receive text messages everytime someone clicks one of the webpages that have the embeddd PHP text script. Between 23:25 and 07:36 ( GMT -7:00) I received fifteen (15) text messages. Matomo tracked one visit.

Okay! The ‘Opps…’ error just popped up and here is the error message:

I hope this helps with your diagnosis.

All of these ‘pings’ are bothersome and am seaching for some analytic tool that can help. Perhaps Wireshark can help with this.

Can you tell me why Matomo is tracking me? I thought this was not supposed to happen, but it is.

Thank you.

The network connection was lost

Your server seems to be very busy… Maybe have a look at the timeout configuration in Matomo and/or memory configuration… Or maybe the SQLserver is not available or overloaded at this time?

Sorry, I don’t understand why you don’t want Matomo track you… There is something I missed

The reason the server is slow is because I have included a PHP text-sending script to try and identify visitors who ‘visit’ and leave. All of these ‘visits’ never appear in the Matomo tracking. These ‘visitors’ are from all over the planet which is highly suspect for the simple reason that they never spend time on the site.

I am also researching why this PHP script is so slow, but that is another matter I hope to soon slove.

My millisecond timer reveals an execution time of 8.90 seconds. Without this embedded script the page load time is 1.5 seconds.

What I was referring to was that Matomo tracks my personal visits to my web page. I thought that tracking script would ignore my visits, but track everyone else who visits web pages embedded with the Matomo tracking script.

Thank you for your help.

Beginning from 0730H until 1325H, I have received 51 texts. These texts are triggered by vistors to my index page. This is the same webpage that the Matomo script is embedded in. Matomo recorded one visit in the ‘Last 24 hours’.

These ‘visitors’ were from several places in the US, Europe and Asia. For some reason the Matomo script is not able to track these web page visits. It would really help me if these visits were being tracked.

If you have any idea how I can improve the Matomo tracking I would really appreciate knowing this information.

Thank you!

If your page takes time to load, maybe the script hasn’t finish to load before the user exits. Then the Matomo script would not have time to load an be be executed (and send tracking).

Before trying to not track you we must be sure your site is well tracking everybody. Did you configure well the tracking exclusions? Maybe you could disable this until you solve the other problem…

Thanks for your comments.

The Matomo script is between the head tags in my index.php web page. The PHP text generating script (that slows down my page load) is below my footer tags, so I would think that the Matomo script should have had time to load by that time. To be certain, I am no expert in any of this, but from what I understand, a web page loads from top to bottom executing CSS scripts, HTML and other scripts as it does so.

I will take another look at the Matomo inclusions you mentioned.

Thank you for your help.

P.S. I had 71 ‘visits’ to my index.php web page yesterday and Matomo did not track a single visit.