Problem with archive.sh script


#1

I’ve got the script in cron and it’s executing, but I don’t believe it’s running correctly.

It doesn’t appear to actually run the archives for each site (I’ve got about 150 sites). I looked at the script and it looks like it should output text like “Archiving period…” – but nothing is output.

From reading previous posts, it seems it’s got something to do with superuser settings.

In my config.inc.php I’ve got:

[superuser]
login = "mylogin"
password = “xxx"
email = "myemail@email.com

The login & password (MD5 encrpyted) matches mine in the system (though note I am using the HttpAuthLogin plugin).

Any ideas?


(Matthieu Aubry) #2

Can you try disable HttpAuthLogin ?


#3

I just disabled it, and no difference in output:

[i]Starting Piwik reports archiving…

Reports archiving finished.

Starting Scheduled tasks…

Error: You can’t access this resource as it requires a ‘superuser’ access.
Finished Scheduled tasks.[/i]


(Matthieu Aubry) #4

is there something in your error log?


#5

Nothing that I can see –

I’m willing to pay someone to troubleshoot this & have sent to Maciej.


#6

I’ve narrowed down the problem (I think) to the script’s inability to get a token_auth.

I tried dumping what it gets, and it just dumps “Array” – so I’m thinking there’s some data issue with the superuser?


(vipsoft) #7

Dan. You have new mail.