Problem updating


#1

I am having a problem updating to the latest version using the auto update:
The following error just broke Piwik (v2.1.0):

Call to undefined method Piwik\Plugins\UsersManager\API::getUsersHavingSuperUserAccess()
in /home/medalia/www/piwik/core/Updates/2.0.4-b7.php line 50

My ISP had to restore my piwk to the last version so I could still use it. Any ideas about how to solve this problem? Thanks for your help.

Ruth


(Matthieu Aubry) #2

It looks like when you upgraded to 2.1.0 you didn’t upload all files properly. Some files were still using 2.0.3 or so


#3

Thanks for the info. I did it more than once and it didn’t go through. I now have the old version in place - it was rolled back. I used the update automatically feature and I didn’t expect any issues. I use a similar feature with wordpress all the time and never have any problems. What do I do now?

Ruth