Problem updating my piwik


(tiw) #1

Hello.

i have a problem with my piwik.
I tried to update my piwik from 0.4.5 to 0.5.5. and got the message “Database upgrade necessary”. I clicked the “upgrade piwik” button and got the message “piwik has been updated”.

BUT when i go back to the piwik start page the statistics are not shown properly.
I get the message (translated from german: Lade Daten… Oops… es ist ein Problem während der Anfrage aufgetreten, bitte noch einmal versuchen.):
“Loading data… oops…an error has occured during the query, please try again.”

I have reset the “version_core” back to “0.4.5” in the “piwik_option” table and tried to update again. Also without success.

I dont have an idea what to do now.
Can you give me a hint?

Best regards!


(rschilt) #2

The automated update was inadvertently broken in 0.4.4 and 0.4.5. If you are running either of these versions, please update manually to 0.5 and beyond.


(tiw) #3

Hi.
Thank you for the answer.

I tried to update the system manually. I have overwrite all files on the ftp-server and later replaced the config files with the old one.

If i go to the startsite of my piwik, i get the mentioned error/update message.

Do you have any idea what else i can do?

Best regards.


(rschilt) #4

Have you had a good look through the Forum to see whether others might have already experienced this issue?


(davidak) #5

i updated from 5.4 to 5.5…

no css is loaded, so its only plain text with links shown.
the database upgrade seams to be done successfull,

im a little bit angry about that, every time in the past it works…
but the whole software is a huge success.

"Dashboard All Websites Widgets API
Hallo, XXX! | Einstellungen | Webseite XXX.de Site
| Abmelden

Piwik 0.5.5 ist ein gemeinschaftliches Projekt.
Wenn Ihnen Piwik gefällt, können Sie helfen! Möchten Sie herausfinden wie Sie zu Piwik beitragen können? Piwik Sonntag 4 April 2010 - Tag | Woche | Monat | Jahr

Lade Daten…
Oops… es ist ein Problem während der Anfrage aufgetreten, bitte noch einmal versuchen."

i hope someone can tell me whats to do.
i could try to upload a fresh version to the server tomorrow.


(vipsoft) #6

It sounds like your webserver doesn’t like the .htaccess files added in 0.5.5. Check your Apache configuration… do you have “AllowOverride None” or “AllowOverride -Limit”?

In themes/.htaccess, plugins/.htaccess, and libs/.htaccess, can you try removing the line:

Order Deny,Allow

???


(davidak) #7

[quote=vipsoft @ Apr 5 2010, 09:36 PM]It sounds like your webserver doesn’t like the .htaccess files added in 0.5.5. Check your Apache configuration… do you have “AllowOverride None” or “AllowOverride -Limit”?

In themes/.htaccess, plugins/.htaccess, and libs/.htaccess, can you try removing the line:

Order Deny,Allow

???[/quote]

Thanks for the fast answer.

there was a problem with the permissions, so the apache-server had no rights to read the .htaccess files.
by taking this to 644 all works fine.

Thanks, great Software!


(tiw) #8

Hello davidak.
That sounds interesting. Its just the same error-message i got.

Can you tell me where this .htaccess-file is located.
In the “root”-directory of piwik i have no .htaccess-file but in the “config”, the “core”, the “js”, the “lang”, the “libs”, the “misc” (called “.htaccess_to_use_later”), the “plugin” and the “themes” directory.

Thanks a lot und Grüße! :slight_smile:


(CharlesD) #9

I have the same problem as all of you.

How can we activate some logs about the database acess ? Or somthing like that ?


(vipsoft) #10

According to davidak, file permissions were the issue.

tiw, CharlesD: Can you chmod 644 .htaccess ?


(tiw) #11

The problem is: i dont know which htaccess-file they were talking about!!! style_emoticons/<#EMO_DIR#>/huh.gif
I have no htaccess-file in the root directory of piwik.


(vipsoft) #12

Focus on libs/.htaccess themes/.htaccess plugins/.htaccessl


(tiw) #13

Setting the filepermissions of:
libs/.htaccess
themes/.htaccess
plugins/.htaccess
to 644 or even on 744 didn’t solve my problem.

BUT, if i delete these files everything works fine.
It is a problem if i delete all the htaccess-files? What did they do? Are they important?

Regards!


(nnteam) #14

Same Problem here… tried to modify the permissions with owner and without but still have the Problem.

I Also deleted the “AllowOverride None” in the Apache config but didnt change anything.

Only by deleting the htaccess files it works, any suggestions?


(randomThing) #15

Same here, just as the previous poster, except the apache config edit since I do not know how to access the file (I am on a commercial hoster).

I do not feel very comfortable with deleting the htaccess files, though that seems the only way piwik works since 0.5.5… style_emoticons/<#EMO_DIR#>/angry.gif

so: bump. style_emoticons/<#EMO_DIR#>/sad.gif


(Matthieu Aubry) #16

Anthon, could we delete these .htaccess? AFAIK they are not mandatory and don’t necessarily help with security (piwik files, accessed directly, can never execute and do something). thoughts?


(vipsoft) #17

I’ll create a ticket for this


(nnteam) #18

There was another AllowOverride statement i didnt see in the Apache Config, which i deleted and now its working style_emoticons/<#EMO_DIR#>/smile.gif


(vipsoft) #19

For 0.6.1, I made the following changes:

  • .htaccess files are generated by the installer and no longer included in the packaged release; so if you had to delete the .htaccess files to make Piwik work, these files won’t re-appear when you auto-update

  • if you unpack the release on your desktop and then ftp the files to your server, you won’t be transferring any .htaccess files – avoiding the permissions issue

  • I’ve also changed the content of the .htaccess files; a file containing simply “Deny from all” doesn’t actually work (oops)

  • finally, I tested with AllowOverride None vs All, and Order deny,allow vs allow,deny

Note: if you have AllowOverride None, the .htaccess files are ignored.