Problem nach Upload des Installationsverzeichnisses


#1

Hallo,

ich habe mir Piwik 2.7.0 heruntergeladen und möchte es auf modified eCommerce Shopssoftware v1.06 rev 4642 SP2 installieren.

Alle Dateien liegen im Ordner /analytics

Den Verzeichnissen config und tmp habe ich Rechte 777 zugewiesen.

Öffne ich jetzt das Verzeichnis: xxxx.de
(wobei "xxx=mein Shop ist) öffnet sich zwar die “Erste Seite” der Installationsroutine von Piwik aber es passiert nichts.
Es steht nur da: # Quelloffene Webanalytik

Screenshot:

In meiner Administrationsübersicht im modified habe ich unter Erweiterte Konfiguration auch alles eingestellt:

Hat jemand eine zündende Idee warum und weshalb es hier nicht weitergeht?

PS. ich war erst im falschen Unterforum, drum jetzt hier an der richtigen Stelle.


#2

Hat niemand eine Hilfreiche Idee wie ich meine Installation durchführen kann?

Bei mir baut sich die Installationsseite nicht auf, obwohl alles am richtigen Ort freigegeben und hochgeladen ist.

Rechte habe ich auch vergeben für die beiden Verzeichnissen “config” und “tmp”.

… Hilfe!


(Stefan Giehl) #3

Welche Version von PHP hast du denn im Einsatz?


#4

Guten Morgen SteveG,

ich habe eben mal auf die Serverinfo geschaut: PHP Version: 5.3.14 (Zend: 2.3.0)

Brauchst du mehr Informationen?

Grüße
bilder


(Stefan Giehl) #5

Ok. Daran sollte es schonmal nicht liegen. Piwik brauch PHP > 5.3.2/3, was hier der fall ist.
Hast du Zugriff auf das Error-Log. Tauchen da irgendwelche Fehlermeldungen auf?


#6

Wenn du mir sagst wie ich drauf zugreifen kann?
Über MyAdminPHP?
Wo genau?

Wenn Piwik PHP 5.3.2/3 benötigt reicht mein 5.3.14 wirklich aus? Ist das nicht niedriger? :slight_smile:


(Stefan Giehl) #7

aktuell ist nicht ganz klar ob PHP 5.3.2 noch unterstützt wird. 5.3.3 auf alle Fälle und 5.3.14 ist höher (14 > 3)

Wie du an die Log-Files kommst ist stark Provider abhängig. Am besten mal auf der Website deines Hosters suchen ob du überhaupt die Möglichkeit hast da ranzukommen.


#8

Hallo,

leider nein. Habe die Möglichkeit nicht, habe sie neulich schon wegen einer anderen Sache suchen sollen.

Ok 14 > also 3 ich bin ein Honk. Hatte 5.3.1.4 im Hinterkopf.

Ist das Problem bekannt? Gab es das schon mal?
Kann ich was von meiner Seite tun was dir hilft?


(Stefan Giehl) #9

Ohne eine Fehlermeldung kann ich leider nicht eingrenzen woran das liegen könnte.
Hast du schonmal versucht Piwik nochmal komplett zu löschen und neu hochzuladen?


#10

Kann ich machen, kein Problem.
filezilla hatte keinen Fehler gemeldet beim Upload, das Installverzeichnis ist auch vollständig.
Ich lade Piwik nochmal neu herunter und versuche es.
Melde mich nochmal.


#11

Habe mir es neu heruntergeladen.
Version 2.8.0
Entpackt, hochgeladen, Dateiberechtigungen und trotzdem, genau das gleiche Problem.

Die Seite öffnet sich aber nur das Logo von Piwik und “# Quelloffene Webanalytik”

Der Inhalt der Installationsroutine fehlt.

Hm…


(Stefan Giehl) #12

Hm. Ohne Log-Files ist das wohl fischen in trüben.
Wie hoch ist denn das Memory-Limit von PHP? Da gab es schonmal einen Post im englischen Forum der den selben Effekt hatte:
http://forum.piwik.org/read.php?2,117910


#13

Hallo,

das Memory Limit liegt bei 32MB

Liegt es daran? Ab wann läuft Piwik?


#14

Hallo
Verwendest du einen Raspberry Pi für die Installation?


#15

Nein.


#16

Oke, ich hatte auch das Problem und hatte es mit den zwei Einstellungen (/etc/nginx/nginx.conf):


http { 
...
fastcgi_send_timeout 600s;
fastcgi_read_timeout 600s;
...
}

beheben können, das lag wohl aber an der Performance des Raspberry Pi. Diese Einstellung wirst du bei deinem Hoster auch nicht ändern können.

Kannst du nicht bei deinem Hosting-Anbieter nachfragen, ob das Problem bekannt ist oder ob sie dir bei der Analyse helfen können?