Problem encountred during update from version 1.8 to 1.9.2

Hi all,
I am a new user of your wonderful “Piwik”.
I am very impressed by this project and I have been using it for over a year.

Yesterday i decide to upgrade my installation of piwik from version 1.8.1 to 1.9.2.
I have used the automatic update and, initially, everything seemed to go well.

I have all my data and configurations migrated to the new version.

But when i click on my settings link the system reports the error attached to this message.
[attachment 1010 piwik_1.9.gif]

I’m still searching through the old posts, but i have not found a solution to my problem yet.
Can anybody help me?

I have seen when a jump from one version to another is too big odd data related issues can come into play espcesially if any major database changes under the hood…

I beleive the one option i might try is ugrade in stages…

1.8.1 to 1.8.4

then try 1.8.4 to 1.9.2

Dear lesjokolat ,
thank you very much for the reply.

Unfortunately i don’t have a backup of the older version.
I tried a fresh install generating a new database, but the result is always the same (same error always in settings section).

It’s possible that my version of php generate this problem?
I have Apache2 and PHP Version 5.2.0 installed on my webserver.

Do you think I can try to downgrade to an older version using the same database without loosing my data?

Older versions can be found here

the apache and php log dont look a problem.

I have never personally tried it but i read another user had some similar problems on the forumn here and i believe he did.

Thank you very much, tomorrow i’ll try and i will report my result!

Can you try reupload all files from a fresh download including that file core/PluginsManager.php ?