[Problem] beim Tracking mehrerer Webseiten


#1

Hallo zusammen,

ich habe aktuell das Problem, dass meine neue Piwik (1.1.1) Installation Seitenzugriffe für eine Webseite zählt, für eine andere Webseite nicht.

Was ich schon versucht habe:
[ul]
[li] Piwik und Datenbanken neu installieren
[/li][li] Trackercode anpassen/neu erstellen
[/li][li] Google Analytics Code entfernt
[/li][li] Vom Cronjob zu Browserarchivierung (und wieder zurück) gestellt
[/li][/ul]

Die Seite, auf der das Tracking (weder Real-time, noch normal) beim besten Willen nicht funktionieren will ist:
http://www.fast-detect.de.

Derzeit habe ich den Trackingcode nur auf der Startseite aktiviert.

Für die eine oder andere Hilfestellung wäre ich sehr dankbar, mir gehen grade die Ideen aus. Zumal das Tracking für eine andere Webseite funktioniert.


(Jens) #2

Hallo!

In Deinem Tracking Code wird auf den Server webstats.compolis.de verwiesen, auf dem Piwik läuft.

Der scheint aber nicht erreichbar zu sein (jedenfalls nicht von mir aus).


#3

Hi Jens,

genau, dort läuft mein piwik.

Wegen der Erreichbarkeit:
Du kannst http://webstats.compolis.de/piwik/piwik.js nicht im Browser öffnen?

user@desktop:~$ host webstats.compolis.de
webstats.compolis.de has address 97.107.141.230


(Jens) #4

Nee, ich kann den server unter http://webstats.compolis.de überhaupt nicht erreichen.
Auch http://webstats.compolis.de/piwik geht nicht.

Irgendwie muss man ja auf die Anmelde-Seite von Piwik kommen.

Nicht mal anpingen kann man den, auch nicht direkt über die IP.


#5

Das ist allerdings sehr seltsam. Bei mir lässt sich http://webstats.compolis.de/piwik einwandfrei öffnen (Achtung: https geht nicht)

Was ergibt ein “dig” bei Dir?

user@desktop:~# dig webstats.compolis.de


; <<>> DiG 9.4.2-P2.1 <<>> webstats.compolis.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10901
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 5

;; QUESTION SECTION:
;webstats.compolis.de.          IN      A

;; ANSWER SECTION:
webstats.compolis.de.   79290   IN      A       97.107.141.230

;; AUTHORITY SECTION:
compolis.de.            1472    IN      NS      nsa5.schlundtech.de.
compolis.de.            1472    IN      NS      nsb5.schlundtech.de.
compolis.de.            1472    IN      NS      nsc5.schlundtech.de.
compolis.de.            1472    IN      NS      nsd5.schlundtech.de.

;; ADDITIONAL SECTION:
nsa5.schlundtech.de.    66796   IN      A       62.116.159.15
nsb5.schlundtech.de.    0       IN      A       217.160.113.55
nsb5.schlundtech.de.    0       IN      A       83.169.55.15
nsc5.schlundtech.de.    66795   IN      A       89.146.248.25
nsd5.schlundtech.de.    66796   IN      A       74.208.254.25

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jan 26 13:52:07 2011
;; MSG SIZE  rcvd: 222


(Jens) #6

Ich habe hier kein Linux (und kenne mich damit auch nicht so sehr aus), weiß daher auch mit “dig” nichts anzufangen.

Ich weiß nur, dass ich http://webstats.compolis.de/piwik von hier nicht aufrufen kann.


#7

Sehr misteriös. Sofern Du grade in der Firma sitzt (und damit eventuell hinter einem Webproxy o.ä.) - kannst Du es mal von daheim probieren?
Danke für deine Mühe!


(Jens) #8

Auch von Zuhause aus funktioniert das nicht … Dort sitze ich nur hinter einer FritzBox, die aber normale http Aufrufe ganz normal durchlässt …


(Thomas Seifert) #9

Also die http://webstats.compolis.de/piwik geht bei mir aber Dein Tracking-Code is kaputt. Nimm doch mal bitte wieder den originalen aus dem Piwik-Adminbereich.
Nach dem was Du da eingebaut hast, versucht die Seite dann so etwas wie
http://www.fast-detect.de/webstats.compolis.de/piwik/piwik.php
aufzurufen und das klappt natürlich nicht.


#10

Danke für den Tipp. Ich hab jetzt zumindest einen Hit beim Aufruf registriert. Werd jetzt genau beobachten wie es aussieht.

Kann ich den https Verweis entfernen? Dort ist der Piwik derzeit nicht erreichbar.


(Thomas Seifert) #11

Sicher, oder trag doch einfach bei beiden URLs im Trackercode http ein :wink:


#12

Ha, guter Tipp! Danke einstweilen, ich halt euch auf dem Laufenden :wink: