Problem after 0.9.9 upgrade, I cant get past the Database Upgrade Required page


(Sherwood) #1

I upgraded but now when I go to log in I get the Database Upgrade Required page
I click upgrade Piwik and get Piwik has been successfully updated! Page
When I click Continue to Piwik I get the Database Upgrade Required page again

Dump of piwik_option table if helps

-- phpMyAdmin SQL Dump
-- version 2.11.9.5
-- http://www.phpmyadmin.net
--

-- Generation Time: Aug 27, 2010 at 02:25 AM
-- Server version: 5.0.37
-- PHP Version: 5.2.2

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";


/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;

--
-- Database: `8709_adbatpwik`
--

-- --------------------------------------------------------

--
-- Table structure for table `piwik_option`
--

CREATE TABLE IF NOT EXISTS `piwik_option` (
  `option_name` varchar(255) NOT NULL,
  `option_value` longtext NOT NULL,
  `autoload` tinyint(4) NOT NULL default '1',
  PRIMARY KEY  (`option_name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8;

--
-- Dumping data for table `piwik_option`
--

INSERT INTO `piwik_option` (`option_name`, `option_value`, `autoload`) VALUES
('version_core', '0.9.9', 1),
('version_CoreAdminHome', '0.9.9', 1),
('version_Login', '0.9.9', 1),
('version_UsersManager', '0.9.9', 1),
('version_SitesManager', '0.9.9', 1),
('version_Installation', '0.9.9', 1),
('UpdateCheck_LatestVersion', '0.9.9', 0),
('UpdateCheck_LastTimeChecked', '1282893728', 1),
('version_CorePluginsAdmin', '0.9.9', 1),
('version_CoreHome', '0.9.9', 1),
('version_API', '0.9.9', 1),
('version_Widgetize', '0.9.9', 1),
('version_LanguagesManager', '0.9.9', 1),
('version_Actions', '0.9.9', 1),
('version_Dashboard', '0.9.9', 1),
('version_MultiSites', '0.9.9', 1),
('version_Referers', '0.9.9', 1),
('version_UserSettings', '0.9.9', 1),
('version_UserCountry', '0.9.9', 1),
('version_VisitsSummary', '0.9.9', 1),
('version_VisitFrequency', '0.9.9', 1),
('version_VisitTime', '0.9.9', 1),
('version_VisitorInterest', '0.9.9', 1),
('version_ExampleAPI', '0.1', 1),
('version_ExamplePlugin', '0.1', 1),
('version_ExampleRssWidget', '0.1', 1),
('version_ExampleFeedburner', '0.1', 1),
('version_Provider', '0.9.9', 1),
('version_Feedback', '0.9.9', 1),
('version_CoreUpdater', '0.9.9', 1),
('version_DBStats', '0.9.9', 1),
('version_Goals', '0.9.9', 1),
('version_Live', '0.9.9', 1),
('lastPurge_piwik_archive_blob_2010_02', '1280205709', 0),
('lastPurge_piwik_archive_blob_2010_01', '1267396934', 0),
('lastPurge_piwik_archive_blob_2010_03', '1280205709', 0),
('version_SEO', '0.6.4', 1),
('enableBrowserTriggerArchiving', '0', 1),
('todayArchiveTimeToLive', '3600', 1),
('Sherwood_defaultReport', '1', 0),
('Sherwood_defaultReportDate', 'yesterday', 0),
('lastPurge_piwik_archive_blob_2010_04', '1280205709', 0),
('SitesManager_DefaultTimezone', 'UTC', 0),
('SitesManager_DefaultCurrency', 'USD', 0),
('SitesManager_ExcludedQueryParameters', '', 0),
('SitesManager_ExcludedIpsGlobal', '', 0);

(Sherwood) #2

Fixed it upgraded to 1.0

version_ExampleAPI
version_ExamplePlugin
version_ExampleRssWidget
version_ExampleFeedburner

Were at 0.1 changed manually to 1.0 and works fine now


(vipsoft) #3

The example plugins are hard-coded at 0.1. That wasn’t the problem.

It looks like your version_SEO stuck at 0.6.4 for some reason.