Probl liste sites


#1

Bonjour,

Je viens d’installer piwik 2.2, tout s’est bien passé, toutes les recommandations sont bonnes.
Le tracking fonctionne bien, le suivi aussi : navigateur, provenance…
Seul problème, le petit menu déroulant n’affiche que le premier site et pas les autres. Ce n’est pas trop gênant sur la page des stats car ont peut accéder au listing des sites et cliquer dessus directement.
La ou c’est problématique c’est dans la gestion des droits des utilisateurs, impossible de les affecter à un autre site que le premier.
index.php?module=UsersManager&action=index&idSite…
Est-ce que quelqu’un a eu un problème de ce genre et sait comment le résoudre ?

Voici le code du menu des utilisateurs



 <!-- ngIf: inputName -->

    <a ng-click="view.showSitesList=!view.showSitesList; view.showSitesList && model.loadInitialSites()" href="javascript:void(0)" class="custom_select_main_link" ng-class="{'loading': model.isLoading}">
        <span class="ng-binding" ng-bind-html="selectedSite.name || model.firstSiteName">site1</span>
    </a>

    <div ng-show="view.showSitesList" class="custom_select_block ng-hide">
        <!-- ngIf: allSitesLocation=='top' && showAllSitesItem --><!-- ngInclude: 'siteselector_allsiteslink.html' --><div class="ng-scope" ng-if="allSitesLocation=='top' && showAllSitesItem" ng-include="'siteselector_allsiteslink.html'">
        <div ng-click="switchSite({idsite: 'all', name: allSitesText});view.showSitesList=false;" class="custom_select_all ng-scope">
            <a class="ng-binding" href="/index.php?idSite=1&period=day&date=yesterday&activated=&module=MultiSites&action=index" piwik-ignore-click="" ng-bind-html="allSitesText"><strong>Appliquer à tous les sites</strong></a>
        </div>
    </div><!-- end ngIf: allSitesLocation=='top' && showAllSitesItem -->

        <div class="custom_select_container">
            <ul class="custom_select_ul_list" ng-click="view.showSitesList=false;">
                <!-- ngRepeat: site in model.sites -->
            </ul>
            <ul ng-show="!model.sites.length && view.searchTerm" class="ui-autocomplete ui-front ui-menu ui-widget ui-widget-content ui-corner-all siteSelect ng-hide">
                <li class="ui-menu-item">
                    <a class="ui-corner-all ng-binding" tabindex="-1">Aucun site trouvé pour </a>
                </li>
            </ul>
        </div>

        <!-- ngIf: allSitesLocation=='bottom' && showAllSitesItem -->

        <div class="custom_select_search ng-hide" ng-show="autocompleteMinSites <= model.sites.length || view.searchTerm">
            <input ng-click="view.searchTerm=''" ng-model="view.searchTerm" ng-change="model.searchSite(view.searchTerm)" class="websiteSearch inp ng-pristine ng-valid" type="text">
            <input ng-click="model.searchSite(view.searchTerm)" value="Rechercher" class="but" type="submit">
            <img title="Clear" ng-show="view.searchTerm" ng-click="view.searchTerm=''; model.loadInitialSites()" class="reset ng-hide" src="plugins/CoreHome/images/reset_search.png">
        </div>
    </div>
</div></div>
    </section>
</div>


(Matthieu Aubry) #2

Apres avoir clique sur le “website selector” pour l’ouvrir, peux tu regarder avec “Firebug” la requete HTTP et voir la reponse ? peut etre il y a une erreur ?
Sinon pourrais tu me PM le Piwik URL + login pwd + lien vers ce sujet pour que je regarde ?