Plugin update not appearing on Marketplace


#1

Hello everyone!

I posted a plugin update over five hours ago, but it still hasn’t appeared on the Marketplace (https://plugins.piwik.org/LoginEncrypted). The only difference in plugin.json is a minor description change and an incremented bug fix version (Comparing 1.0.1...1.0.2 · Joey3000/piwik-LoginEncrypted · GitHub).

The previous update appeared after about a minute of its release creation on Github.

Does anyone know what happened?


#2

I’ve tried the “Test service” (in Services / Manage Piwik Plugins) of the Github repo - “Okay, the test payload is on its way” appears, but the updated version still doesn’t appear on the Marketplace.

P.S.: The commits to the Github repo aren’t counted under “Activity” on https://plugins.piwik.org/LoginEncrypted any longer either, although they used to be earlier.

I don’t know if I should delete the existing Github service hook and set up an new one, or if that would result in the plugin being recognized as a different one, resulting in its rejection by the Marketplace due to an already existing plugin of the same name. (If that is not the issue here already, for whatever reason.)


#3

Status: Deleted and re-created the web service in Github, released a new version, but it still doesn’t appear on the Marketplace.


(Matthieu Aubry) #4

jawsmith, if you still have a problem, please contact us at marketplace att piwik.org


#5

Thanks @matt! I wrote to that address, haven’t got a response, but the latest version has automagically appeared on the Marketplace some days later. So, this topic is solved for me.