PiwiklFatal error: Class 'Piwik_Session' not found in /.../.../.../index.php on line 0


#1

Hi Guys,

I had installed Piwik and when i run the start parge i have that error. Can anyone help ?

Fatal error: Class ‘Piwik_Session’ not found in /…/…/…/index.php on line 0

Thx in advance


(vipsoft) #2

By “installed”, do you mean “unzipped” only, or did you go through the GUI installation steps?


#3

hi, i did not instll it … another guy did it … i asked him now … and he sait that it worked just fine … untill he made an update … after that he had that error …


(peterwhite88) #4

I encountered the same problem. Hope some can help. Thanks a lot!


#5

hi guys … any ideea ? how can we solve that problem ? :smiley:


(DukeJustice) #6

Issue still appearing many months after…

I have:


Fatal error: Class 'Piwik_Session' not found in /.../.../.../index.php [b]on line 62[/b]

This is following upgrade procedure to version 1.1.1, right after pasting/replacing all files, recuperating the config and accessing the index page.

And line 62 doesn’t even exist!!!

I am told that version 1.1 is a security upgrade but upgrade fails.

Any idea?


(vipsoft) #7

Did you manually update? The Piwik_Session class is found in core/Session.php.

http://dev.piwik.org/trac/export/3650/trunk/core/Session.php


(DukeJustice) #8

Hi

I unzipped and uploaded the latest.zip download from a few hours ago.

I don’t know why it is not working. Re-did the manual upgrade procedure with same results.

It seems I cannot upgrade.

Any pointers?


(vipsoft) #9

Can you check your phpinfo? if you have eaccelerator, you have to disable it. it doesn’t work with the autoloader. eaccelerator users were getting errors with zend_registry but I’m guessing it’s erroring on Zend_Session (which Piwik_Session subclasses).


(DukeJustice) #10

Thanks for the answer.

I confirm there are no eaccelerator installed. Some of my websites, not this one, have compression enabled so html is zipped before being sent to the visitor.

Other then that, I am using LAMP all in their latest versions available (not bleeding edge, stable releases).

Any other ideas?

Best regards.

Marc


#11

I have the same problem. I hope what I found here will help me.
Thanks


(DukeJustice) #12

Hi.

I confirm that zlib is not active on this domain and that no other form of eaccelerator are installed on the server.

I am still stuck!

Anything else you suggest I check?

Regards

Marc


(vipsoft) #13

Can you PM your phpinfo? It looks like there’s something atypical about your runtime environment.