Piwik0.41 on Solaris10 : Signal Segmentation fault (11) occurs during piwik installation


(Alfredwan) #1

Hi guys,

I was trying to setup piwik 0.41 on my company’s Solaris10 server with MySQL5.1.37 + PHP5.2.9 + Apache2.0.59.

However, I met a really weird error which takes me very long time to investigate but still did not get solved - when installing piwik 0.41, first 5 steps work fine (you can check the installation guide via link below), on step06 apache throws error: “[notice] child pid 3733 exit signal Segmentation fault (11), possible coredump in /export/home/apache2”, and browser shows “page cannot be displayed”
http://piwik.org/docs/installation/

Our current apache is version 2.0.59, I also tried 2.2.12, still the same error. And I tried different Mysql versions and PHP versions, got same error.

Any suggestion on resolving the problem is really appreciated!

Thanks,
Alfred

PS. phpinfo page is attached for your diagnosis.


(vipsoft) #2

Since Piwik is written in an interpreted language, there isn’t much we can do if the crash lies in PHP.

Can you try Piwik 0.4.2 and PHP 5.2.10 (or 5.3)?


(Alfredwan) #3

To answer my own question,

The root cause of this issue was: Solaris10’s native GCC used Sun ld which did not compiled mysql and php correctly.

To solve the problem, I installed GNU GCC 4.3.3 using GNU ld and re-compiled mysql and php with it.

Now the problem is fixed.