Piwik update error


#1

I recieve this error when using the onelick update option:

[b]There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: Invalid argument supplied for foreach() in /var/www/wp/piwik/core/Unzip/PclZip.php on line 37

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [/var/www/wp/piwik/core/Unzip/PclZip.php:37]#1 Piwik_Unzip_PclZip->extract(…) called at [/var/www/wp/piwik/plugins/CoreUpdater/Controller.php:109]#2 Piwik_CoreUpdater_Controller->oneClick_Unpack(…) called at [/var/www/wp/piwik/plugins/CoreUpdater/Controller.php:63]#3 Piwik_CoreUpdater_Controller->oneClickUpdate(…) called at [:]#4 call_user_func_array(…) called at [/var/www/wp/piwik/core/FrontController.php:132]#5 Piwik_FrontController->dispatch(…) called at [/var/www/wp/piwik/index.php:53][/b]

What is wrong and how can I fix this?


(Matthieu Aubry) #2

Can you try again the automatic upgrade? do you get the same message again?

I created a ticket :Catch automatic upgrade errors and ask user to try again · Issue #2971 · matomo-org/matomo · GitHub

but I am curious to know if it works when you try again?


#3

I rebooted my server, and the update process just seems to be hanging now :/.

Before I go for a manual update, are there any log files or prudent information I should upload from my server?


(Matthieu Aubry) #4

There is no need to reboot your server. What do you mean it’s hanging?


#5

I hit Update Automatically and it loads continuously with out ever ending.


(Matthieu Aubry) #6

do you see an error in your error log?

Have you waited 2-3 minutes?


#7

I waited for more than an hour and I don’t see anything relating to piwik in apaches error logs.


(vipsoft) #8

Please look in piwik/tmp/latest/

Is the latest.zip file present? is it empty (i.e., zero-length file)? is it corrupt? (try using: unzip -t latest.zip)


#9

The latest.zip file was corrupt :slight_smile: I deleted it and then used wget to redownload. Piwik then updated itself like a charm.

Thanks for the help!


#10

Hi,
I have the same problem when trying to update to v 1.7.1
PCLZIP_ERR_WRITE_OPEN_FAIL (-1) Newer version of ‘/var/www/virtual/domain.com/piw/htdocs/tmp/latest/How to install Piwik.html’ exists and option PCLZIP_OPT_REPLACE_NEWER is not selected

I tested the zip file and it said: No errors detected in compressed data of latest.zip.

Still no updating.
What could it be?

Additionally, I dont understand, why there anyway exists a file with spaces in the filename.
No linux system can handle them…

Cheers.
Andre


(vipsoft) #11

It means the timestamp for that file is newer than the one in the upgrade package. We should always overwrite.

See patch:

http://dev.piwik.org/trac/changeset/6224


#12

thanks… ! worked like a charm